Closed Bug 1378455 Opened 3 years ago Closed 2 years ago

Regression in behaviour of async-scrolling offscreen scrollbar thumb inside iframe

Categories

(Core :: Layout, defect, P3)

55 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed

People

(Reporter: botond, Assigned: mattwoodrow)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

STR:
  1. Load https://people-mozilla.org/~bballo/bug1359868.html
  2. Unmaximize the Firefox window if necessary, and position it
     so that there's space below it.
  3. Grab the subframe's scroll thumb near the top.
  4. Drag it down until mouse leaves the Firefox window, and then back up.

Expected results:

  The scrollbar thumb is fully painted when you drag it back up.

Actual results:

  - Sometimes, the thumb is not painted at all.
  - Sometimes, a non-contiguous subset of the thumb is painted.
  - Sometimes, the thumb is painted but is larger than it
    should be (it extends to the bottom of the screen even
    when you've dragged it high enough that is hould end
    before that).

This is a regression; it worked a month or so ago, when the fix for bug 1367488 landed, and it's broken now.
(In reply to Botond Ballo [:botond] from comment #0)
> This is a regression; it worked a month or so ago, when the fix for bug
> 1367488 landed, and it's broken now.

Mozregression pointed me to the following regression range:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=958d2a5d10091401fd5e900e8e063d21940c137e&tochange=7f894f791cdf170d788507d0eff30024ce699523

Bug 1361970 is in that range; as it has caused similar rendering issues, I assume it's the culprit.
Blocks: 1361970
Component: Panning and Zooming → Layout
Flags: needinfo?(matt.woodrow)
(In reply to Botond Ballo [:botond] from comment #1)
> Bug 1361970 is in that range; as it has caused similar rendering issues, I
> assume it's the culprit.

I confirmed that backing out bug 1361970 locally fixes the problem (I also had to back out bug 1373335 to get the backout of bug 1361970 to apply cleanly).
Version: unspecified → 55 Branch
Priority: -- → P2
Hi Botond,
I tried to load https://people-mozilla.org/~bballo/bug1359868.html in order to reproduce this issue, but the link doesn't work.
(In reply to ovidiu boca[:Ovidiu] from comment #3)
> Hi Botond,
> I tried to load https://people-mozilla.org/~bballo/bug1359868.html in order
> to reproduce this issue, but the link doesn't work.

Please use https://theres-waldo.github.io/mozilla-testcases/bug1359868.html.
Thanks for the URL,

I tested again on Mac OS X 10.10 and Windows 10 x64 with FF beta55.0b8 I can't reproduce it, but with Nightly 56.0a1(2017-07-12) it's reproducible if I zoom in the page to 160% and drag it down until mouse leaves the Firefox window, and then back up. If the I don't zoom in the issue is not reproducible. Please see bug 1363219, I think there are related.
(In reply to ovidiu boca[:Ovidiu] from comment #5)
> I tested again on Mac OS X 10.10 and Windows 10 x64 with FF beta55.0b8 I
> can't reproduce it, but with Nightly 56.0a1(2017-07-12) it's reproducible if
> I zoom in the page to 160% and drag it down until mouse leaves the Firefox
> window, and then back up. If the I don't zoom in the issue is not
> reproducible. Please see bug 1363219, I think there are related.

I've got the same result on my local tests across macOS, Win10 x64.
Botond, could you verify that on latest 55.0b9?
Flags: needinfo?(botond)
Priority: P2 → P3
I can verify that I do not see the issue in Beta (tested with 55.0b10). That makes sense as the regressing bug, bug 1361970, landed in 56.

I do still see the issue in Nightly, even without zooming in; please see the screenshot I'm about to attach. I'm testing with Linux, but I can check Windows as well on Friday.
Flags: needinfo?(botond)
(In reply to Botond Ballo [:botond] from comment #7)
> I can verify that I do not see the issue in Beta (tested with 55.0b10). That
> makes sense as the regressing bug, bug 1361970, landed in 56.
> 
> I do still see the issue in Nightly, even without zooming in; please see the
> screenshot I'm about to attach. I'm testing with Linux, but I can check
> Windows as well on Friday.

I can confirm that I see the same results on Windows: correct behaviour on Beta, buggy behaviour on Nightly (zooming in not required).
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
This is the same as bug 1373479, except for scrollbar thumbs instead of async animations.
Attachment #8890120 - Flags: review?(mstange)
Attachment #8890120 - Flags: review?(mstange) → review+
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a9f00bf0aeff
Don't minimize the visible region for the scrollbar thumb in FrameLayerBuilder since it can move asynchronously. r=mstange
https://hg.mozilla.org/mozilla-central/rev/a9f00bf0aeff
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.