Display different welcome messages for update or new users on the overlay tour icon

VERIFIED FIXED in Firefox 56

Status

()

enhancement
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: rexboy, Assigned: rexboy)

Tracking

unspecified
Firefox 56
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [photon-onboarding] )

Attachments

(3 attachments)

We'll have updated tours on version 57 which needs different welcome messages.

UX spec string followup needed for:
- Updated user tip for overlay icon
- Updated user tip for notification
Assignee: nobody → rexboy
See bug 1360378 comment 5 for the follow-up string. The string is current in review now so I'll just come up a WIP until they are locked down.
So here comes the WIP.
Target Milestone: --- → Firefox 57
Flags: qe-verify+
Status: NEW → ASSIGNED
QA Contact: jwilliams
Comment hidden (mozreview-request)
The strings has been locked down per bug 1360378 comment 5 so let's step forward.
I'll give out a screenshot later.

Comment 8

2 years ago
mozreview-review
Comment on attachment 8886948 [details]
Bug 1380963 - Display different welcome messages for update or new users on the overlay tour icon.

https://reviewboard.mozilla.org/r/157714/#review163360

::: browser/extensions/onboarding/locales/en-US/onboarding.properties:13
(Diff revision 2)
>  onboarding.button.learnMore=Learn More
>  # LOCALIZATION NOTE(onboarding.overlay-icon-tool-tip): This string will be used to show the tooltip alongside the notification icon. %S is brandShortName.
>  onboarding.overlay-icon-tool-tip=New to %S? Let’s get started.
>  # LOCALIZATION NOTE(onboarding.notification-icon-tool-tip): This string will be used to show the tooltip alongside the notification icon. %S is brandShortName.
>  onboarding.notification-icon-tool-tip=New to %S?
> +# LOCALIZATION NOTE(onboarding.overlay-icon-tool-tip-updated): %S is brandShortName.

nit: tooltip is one word, so I'd avoid tool-tip in these string IDs

::: browser/extensions/onboarding/locales/en-US/onboarding.properties:15
(Diff revision 2)
>  onboarding.overlay-icon-tool-tip=New to %S? Let’s get started.
>  # LOCALIZATION NOTE(onboarding.notification-icon-tool-tip): This string will be used to show the tooltip alongside the notification icon. %S is brandShortName.
>  onboarding.notification-icon-tool-tip=New to %S?
> +# LOCALIZATION NOTE(onboarding.overlay-icon-tool-tip-updated): %S is brandShortName.
> +onboarding.overlay-icon-tool-tip-updated=%S is all new. See what you can do!
> +onboarding.notification-icon-tool-tip-updated=See what's new!

Use proper apostrophe ’, otherwise this will fail tests.
(In reply to Francesco Lodolo [:flod] from comment #8)
> nit: tooltip is one word, so I'd avoid tool-tip in these string IDs

To clarify: I'd use icon-tooltip instead of icon-tool-tip

Comment 10

2 years ago
mozreview-review
Comment on attachment 8886948 [details]
Bug 1380963 - Display different welcome messages for update or new users on the overlay tour icon.

https://reviewboard.mozilla.org/r/157714/#review163416

::: browser/extensions/onboarding/content/onboarding.js:656
(Diff revision 2)
>          <button id="onboarding-notification-action-btn"></button>
>        </section>
>        <button id="onboarding-notification-close-btn"></button>
>      `;
> -    let toolTip = this._bundle.formatStringFromName("onboarding.notification-icon-tool-tip", [BRAND_SHORT_NAME], 1);
> +    let toolTip = this._bundle.formatStringFromName(
> +      this._tourType == "new" ? "onboarding.notification-icon-tool-tip"

===

::: browser/extensions/onboarding/content/onboarding.js:706
(Diff revision 2)
>  
>    _renderOverlayIcon() {
>      let icon = this._window.document.createElement("button");
>      icon.id = "onboarding-overlay-icon";
> -    let tooltip = this._bundle.formatStringFromName("onboarding.overlay-icon-tool-tip", [BRAND_SHORT_NAME], 1);
> +    let tooltip = this._bundle.formatStringFromName(
> +      this._tourType == "new" ? "onboarding.overlay-icon-tool-tip"

===

::: browser/extensions/onboarding/content/onboarding.js:707
(Diff revision 2)
>    _renderOverlayIcon() {
>      let icon = this._window.document.createElement("button");
>      icon.id = "onboarding-overlay-icon";
> -    let tooltip = this._bundle.formatStringFromName("onboarding.overlay-icon-tool-tip", [BRAND_SHORT_NAME], 1);
> +    let tooltip = this._bundle.formatStringFromName(
> +      this._tourType == "new" ? "onboarding.overlay-icon-tool-tip"
> +                              : "onboarding.overlay-icon-tool-tip-updated",

lint: `:` should append at the previous line
Comment hidden (mozreview-request)

Comment 12

2 years ago
mozreview-review
Comment on attachment 8886948 [details]
Bug 1380963 - Display different welcome messages for update or new users on the overlay tour icon.

https://reviewboard.mozilla.org/r/157714/#review163992
Attachment #8886948 - Flags: review?(francesco.lodolo) → review+

Comment 13

2 years ago
mozreview-review
Comment on attachment 8886948 [details]
Bug 1380963 - Display different welcome messages for update or new users on the overlay tour icon.

https://reviewboard.mozilla.org/r/157714/#review164362
Attachment #8886948 - Flags: review?(dtownsend) → review+

Comment 14

2 years ago
mozreview-review
Comment on attachment 8886948 [details]
Bug 1380963 - Display different welcome messages for update or new users on the overlay tour icon.

https://reviewboard.mozilla.org/r/157714/#review164418
Attachment #8886948 - Flags: review?(gasolin) → review+

Comment 15

2 years ago
hg error in cmd: hg push -r . -f try: pushing to ssh://hg.mozilla.org/try
searching for changes
remote: adding changesets
remote: adding manifests
remote: adding file changes
remote: added 1 changesets with 0 changes to 0 files (+1 heads)
remote: 
remote: 
remote: ************************** ERROR ****************************
remote: Error accessing https://api.pub.build.mozilla.org/treestatus/trees/try :
remote: HTTP Error 500: INTERNAL SERVER ERROR
remote: Unable to check if the tree is open - treating as if CLOSED.
remote: To push regardless, include "CLOSED TREE" in your push comment.
remote: *************************************************************
remote: 
remote: 
remote: transaction abort!
remote: rollback completed
remote: pretxnchangegroup.a_treeclosure hook failed
abort: push failed on remote
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Updated

2 years ago
Blocks: 1377439

Updated

2 years ago
Duplicate of this bug: 1382554
FWIW, our traditional way of using Target Milestone is that it corresponds to when code hits mozilla-central.
Target Milestone: Firefox 57 → ---

Comment 20

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/05e27c93b3b4
Display different welcome messages for update or new users on the overlay tour icon.r=flod,gasolin,mossop
Keywords: checkin-needed
Duplicate of this bug: 1381360
(In reply to Ryan VanderMeulen [:RyanVM] from comment #19)
> FWIW, our traditional way of using Target Milestone is that it corresponds
> to when code hits mozilla-central.
Got you. This feature is planned to be opened in version 57; We just planned our development schedule earlier. Otherwise there's a very short period before feature freeze.
If that should correspond to the actual time patch landed, I can change it to 56.
Target Milestone: --- → Firefox 56
https://hg.mozilla.org/mozilla-central/rev/05e27c93b3b4
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
I updated from 55 to 57 and got the "New to Nightly" message. Is there a specific way to provoke these actions?
Flags: needinfo?(rexboy)
That's a little bit strange because you should get nothing for a 55-to-57 upgrade for now. (whereas after bug 1366056 landed later, it should shows correct set of updated tours).

But in any way you need to trigger it manually for now.
To trigger an updated tour manually, change the following two preferences:
browser.onboarding.tour-type: set to "true".
browser.onboarding.updatetour: set to some reasonable toursets like "performance,library,singlesearch,customize,sync".
Flags: needinfo?(rexboy)
Sorry for the typo.

browser.onboarding.tour-type: set to "update".
browser.onboarding.updatetour: set to some reasonable toursets like "performance,library,singlesearch,customize,sync".
Thanks Rex. I was able to verify this bug on today's nightly with Rex's steps in Comment 27.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.