Synthesizing touch/tap events does not work in Windows 10 automation

RESOLVED DUPLICATE of bug 1388356

Status

RESOLVED DUPLICATE of bug 1388356
a year ago
a year ago

People

(Reporter: johannh, Unassigned)

Tracking

Version 3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Anything that uses nsIDOMWindowUtils.sendNativeTouchTap fails on Win 10 infrastructure while running fine locally. This is causing some of the current Win 10 perma-failures, AFAICS.

I noticed this after landing browser/base/content/test/contextMenu/browser_contextmenu_touch.js which is currently only run on Windows 10. I thought it was an intermittent issue or related to bug 1373551. But now I'm hitting the same problem while working on bug 1371219.

Looking at https://treeherder.mozilla.org/#/jobs?repo=try&revision=183c12a687d1bd2ceee68547857f37ff91803d13&group_state=expanded&exclusion_profile=false, other affected tests seem to be:

gfx/layers/apz/test/mochitest/test_group_touchevents.html
dom/events/test/pointerevents/test_touch_action.html
and maybe dom/tests/mochitest/pointerlock/test_pointerlock-api.html

Can someone confirm that I'm interpreting these failures correctly?
(Reporter)

Updated

a year ago
Blocks: 1352356
(Reporter)

Updated

a year ago
Summary: Synthesizing tap events does not work in Windows 10 automation → Synthesizing touch/tap events does not work in Windows 10 automation
I think this is a valid assessment.  As to why these would be failing, I don't have a lot of ideas.  Possibly the virtualization + win10 is problematic- does this work in win7 without problems?  Specifically on taskcluster?
(Reporter)

Comment 2

a year ago
(In reply to Joel Maher ( :jmaher) (UTC-8) from comment #1)
> I think this is a valid assessment.  As to why these would be failing, I
> don't have a lot of ideas.  Possibly the virtualization + win10 is
> problematic- does this work in win7 without problems?  Specifically on
> taskcluster?

Sorry, I think I can't test that right now. The feature I'm testing is currently only enabled on Windows 10. Even if I'd remove that restriction, looking at https://searchfox.org/mozilla-central/rev/3a3af33f513071ea829debdfbc628caebcdf6996/dom/interfaces/base/nsIDOMWindowUtils.idl#759 it seems like the synthesize function wouldn't work on Windows 7 anyway.

I'm happy to wait until next week when Win 10 is running on taskcluster, as far as I understand.
(Reporter)

Comment 3

a year ago
It's still happening after the switch to taskcluster, I'm afraid.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ea4354f71478e6f9fa93349b864e592bf4d494f5&filter-tier=1&filter-tier=2&filter-tier=3&selectedJob=120392136

I still kind of hope that there's a simple solution like touch events being disabled for these VMs.
No longer blocks: 1326419
Blocks: 1326419
mochitest-plain should be ready to go now that I just landed bug 1388356; I think we can close this bug out.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1388356
(Reporter)

Comment 6

a year ago
It doesn't look like bug 1388356 fixes browser_contextmenu_touch.js. Do we have a plan for tracking/fixing that?
Flags: needinfo?(jmaher)
thanks for mentioning that, there are 2 touch bugs that need attention in browser-chrome:
browser\base\content\test\contextMenu\browser_contextmenu_touch.js - fixed with "apz.test.fails_with_native_injection"=true
browser_contextmenu_touch.js - bug 1388512 - not fixed by above pref, possibly missing element by id
Flags: needinfo?(jmaher)
You need to log in before you can comment on or make changes to this bug.