Closed Bug 1385703 Opened 3 years ago Closed 3 years ago

warning: & has lower precedence than == in elfhack.cpp

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1385537

People

(Reporter: Sylvestre, Assigned: Sylvestre)

References

(Blocks 1 open bug)

Details

Attachments

(1 obsolete file)

warning: build/unix/elfhack/elfhack.cpp:733:37 [-Wparentheses] & has lower precedence than ==; == will be evaluated first

with clang 

Even if this is pretty obvious in the code, we should just silent it.
Blocks: 635961
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1385537
Attachment #8891738 - Attachment is obsolete: true
Attachment #8891738 - Flags: review?(mh+mozilla)
No longer blocks: clang-based-analysis
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.