Closed Bug 138646 Opened 20 years ago Closed 16 years ago

textbox.blur() and textarea.blur() steal focus from other Mozilla windows

Categories

(Core :: XUL, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: sven.jost, Assigned: jag+mozilla)

References

()

Details

(Keywords: helpwanted, regression, testcase)

Attachments

(2 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

setTimeout javascripts steal the focus of all opened windows/tabs
by resetting a text value.

Reproducible: Always
Steps to Reproduce:
1. go to
   http://starwars.gamigo.de/ticker/
   or directly to
   http://starwars.gamigo.de/ticker/countdown.php?id=1

Actual Results:  the timer steals the focus of all opened windows per second.

This bug is not a duplicate of bug 82534.
This is due to the incomplete fix for bug 41813.
Assignee: rogerl → jaggernaut
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → XP Toolkit/Widgets
Ever confirmed: true
OS: Linux → All
QA Contact: pschwartau → jrgm
Hardware: PC → All
Summary: javascript steals focus of url bar & other textboxes → textbox.blur() steals focus from other Mozilla windows
Keywords: regression
Blocks: 140346
*** Bug 157897 has been marked as a duplicate of this bug. ***
*** Bug 184103 has been marked as a duplicate of this bug. ***
Attached file demo input
modified demo lent from bug 265055
Attached file demo textarea
Bug is also present in textarea.blur()
Attachment #165140 - Attachment description: demo → demo input
Keywords: helpwanted
Summary: textbox.blur() steals focus from other Mozilla windows → textbox.blur() and textarea.blur() steal focus from other Mozilla windows
Better Blur() Method should be look like this:

NS_IMETHODIMP
nsHTMLTextAreaElement::Blur()
{
  nsIFormControlFrame* formControlFrame = GetFormControlFrame(PR_TRUE);

  if (formControlFrame) {
    SetElementFocus(PR_FALSE);
  }

  return NS_OK;
}

Is this okay? I need help.
Keywords: testcase
This is fixed by bug 299677.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.