Closed Bug 1386643 Opened 4 years ago Closed 4 years ago

Vibrancy in the titlebar plus tab title fade results in a strangely bold tab title

Categories

(Core :: Widget: Cocoa, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 + fixed

People

(Reporter: mconley, Assigned: mstange)

References

Details

(Keywords: regression, Whiteboard: tpi:+)

Attachments

(5 files)

Attached image Bold title
This summary might not be 100% clear, but the attached screenshot might help.

Interestingly, this only seems to affect tabs that have titles long enough to fade on the right side.

I remember showing this to nhnt11 when we were fiddling with vibrancy in SF, and there was some macOS accessibility setting that seemed to affect this involving text smoothing, but I can't find the setting... nhnt11, do you remember what that setting was?
Flags: needinfo?(nhnt11)
Any idea what's happening here, mstange?
Flags: needinfo?(mstange)
Either something's wrong with the mask's PushGroupAndCopyBackground, or we're giving some intermediate surface the wrong FontSmoothingBackgroundColor, or something else is broken. I'll look into it.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Flags: needinfo?(mstange)
(In reply to Mike Conley (:mconley) - Buried in needinfo / review backlog, eating my way out from comment #0)
> Created attachment 8892915 [details]
> Bold title
> 
> This summary might not be 100% clear, but the attached screenshot might help.
> 
> Interestingly, this only seems to affect tabs that have titles long enough
> to fade on the right side.
> 
> I remember showing this to nhnt11 when we were fiddling with vibrancy in SF,
> and there was some macOS accessibility setting that seemed to affect this
> involving text smoothing, but I can't find the setting... nhnt11, do you
> remember what that setting was?

That setting is "Use LCD font smoothing when available" in System Preferences' General pane.
Flags: needinfo?(nhnt11)
Duplicate of this bug: 1387093
Cameron, is this what you were seeing earlier and mentioned on slack? :-)
Flags: needinfo?(cam)
Duplicate of this bug: 1387138
This also happens when you mouse over, and it seems to affect the URL bar too, here's a video:

https://www.dropbox.com/s/9eqba6tbigpde4t/tab%20font%20weirdness.mov?dl=0
Duplicate of this bug: 1387202
(In reply to :Gijs from comment #7)
> Cameron, is this what you were seeing earlier and mentioned on slack? :-)

It is indeed, thanks!
Flags: needinfo?(cam)
Depends on: 1387594
Duplicate of this bug: 1387734
Duplicate of this bug: 1387781
Duplicate of this bug: 1387603
This seems to only happen in the default theme.  It doesn't happen with Light or Dark themes from customize options.  I switched to the Light theme several days ago to avoid the flickery/focusy issue on tab hover.
Keywords: regression
Priority: -- → P4
Whiteboard: tpi:+
I wonder what this priority means. It's a visual regression in the default theme and it's a visual regression in one of the most important parts of the user interface of the browser: the tabs. And the flickering is *very* annoying. So this should be rather a P1 than a P4, no?
I agree.
Comment on attachment 8893111 [details]
Bug 1386643 - Don't respect font smoothing background colors in pushed layers.

https://reviewboard.mozilla.org/r/164114/#review171724
Attachment #8893111 - Flags: review?(jmuizelaar) → review+
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/b75150e59554
Don't respect font smoothing background colors in pushed layers. r=jrmuizel
Duplicate of this bug: 1389127
https://hg.mozilla.org/mozilla-central/rev/b75150e59554
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Attached video bug
It's not fixed. I looks a bit different now, but the problem is still there.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 1389476
On macOS (10.11) it seems that the effect on the active tab and the URL bar has been fixed. Only the background tabs still show the font-weight change on hover.
This bug was about the selected tab, which is no longer strangely bold.

The bug about bad text anti-aliasing when hovering background tabs needs a separate fix and will be tracked in bug 1389476.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Depends on: 1389518
(In reply to Markus Stange [:mstange] from comment #25)
> This bug was about the selected tab, which is no longer strangely bold.
> 
> The bug about bad text anti-aliasing when hovering background tabs needs a
> separate fix and will be tracked in bug 1389476.

well, this was not clear since I reported the issue already 10 days ago and my ticket was marked as duplicate of this ticket. Okay, I'll follow the other ticket. Thanks. ;)
You need to log in before you can comment on or make changes to this bug.