Disable predictor prefetch (again!)

RESOLVED FIXED in Firefox 55

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: u408661, Assigned: u408661)

Tracking

unspecified
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 verified, firefox56 fixed, firefox57 verified)

Details

(Whiteboard: [necko-active])

Attachments

(1 attachment)

59 bytes, text/x-review-board-request
jduell.mcbugs
: review+
Details
We need to do this on nightly 57 and beta 56, based on a new email from Y! saying the previous fix didn't entirely fix the issue on their end.
Comment on attachment 8894692 [details]
Bug 1388160 - Disable prefetch (again).

https://reviewboard.mozilla.org/r/165854/#review171022
Attachment #8894692 - Flags: review?(jduell.mcbugs) → review+
Pushed by hurley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce2b6a193210
Disable prefetch (again). r=jduell
Whiteboard: [necko-active]
Comment on attachment 8894692 [details]
Bug 1388160 - Disable prefetch (again).

Approval Request Comment
[Feature/Bug causing the regression]: predictor prefetch
[User impact if declined]: causes unwanted duplicate requests to ad networks
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes (just not this particular landing of the pref flip)
[Needs manual test from QE? If yes, steps to reproduce]: nope
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple pref flip, that's been flipped before
[String changes made/needed]: none
Attachment #8894692 - Flags: approval-mozilla-beta?
Comment on attachment 8894692 [details]
Bug 1388160 - Disable prefetch (again).

See above for approval request comment. Requesting approval for release so this can hit any dot release we make for 55. We have bug 1388158 to send out a pref flip add-on to handle 55.0, so we shouldn't have to make a dot release just for this :)
Attachment #8894692 - Flags: approval-mozilla-release?
Improved noticed due to this change:

== Change summary for alert #8637 (as of August 08 2017 17:04 UTC) ==

Improvements:

  2%  tp5o_webext summary windows7-32 opt e10s     331.84 -> 324.03

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=8637
Comment on attachment 8894692 [details]
Bug 1388160 - Disable prefetch (again).

OK, let's take it for 55.0.1 and for 56.0beta2.
Attachment #8894692 - Flags: approval-mozilla-release?
Attachment #8894692 - Flags: approval-mozilla-release+
Attachment #8894692 - Flags: approval-mozilla-beta?
Attachment #8894692 - Flags: approval-mozilla-beta+
Nicholas or Jason, for posterity, could you give us the bug number in which we disabled it the first time? thanks
(I tried to needinfo Nicholas but he is refusing them)
Flags: needinfo?(jduell.mcbugs)
https://hg.mozilla.org/mozilla-central/rev/ce2b6a193210
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
was it available on firefox for android?
Thanks
Dragana answered to my question:
<dragana> Sylvestre: no, it is not desktop only. I do not see any #ifdefs and there is no such a pref entry in the android only prefs file
We've disabled it at least a few times.  Bugzilla is being very weird for me (search for "predictor" doesn't turn up many bugs, but "Disable predictor prefetch" turns up bug 1268208 and bug 1278636.
Flags: needinfo?(jduell.mcbugs)
Flags: qe-verify+
the pref "network.predictor.enable-prefetch" is set to "false" in 55.0.1 build2 and Nightly 57.0a1 on the following OSs:
- Windows 10 x64
- Windows 7 x64
- Ubuntu 16.04 x86
- macOS 10.12.6
We will build a 55.0.1 for fennec, so, it will be disabled in this product too.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.