Open Bug 1388326 Opened 3 years ago Updated 2 years ago

VMware vSphere Web Client (Flash) is not working on Firefox 55 32-bit

Categories

(Core :: Plug-ins, defect, P2)

55 Branch
x86
Unspecified
defect

Tracking

()

People

(Reporter: banmenau, Unassigned)

References

Details

(Keywords: flashplayer, regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170803103124

Steps to reproduce:

open the VMware vSphere Web Client (Flash) 6.5, trying to work but cant do nothing


Actual results:

Cant select anything, nothing moves or do in this page


Expected results:

Select something
Component: Untriaged → Plug-ins
Keywords: flashplayer
Product: Firefox → Core
Hardware: Unspecified → x86
Summary: vSphere Web Client (Flash) working → VMware vSphere Web Client (Flash) is not working on Firefox 55 32-bit
Duplicate of this bug: 1390845
I had no problems with Firefox version 54. There was a change in 55. I have tried 55.0.1 and 55.0.2 and still not working. I have to revert back to v54 to make vSphere work again.
Hello Troy. Could you please try to find a regression range using Mozregression tool?
Information on the tool is available at http://mozilla.github.io/mozregression/. Please don't hesitate to contact us if you encounter any problems.
Flags: needinfo?(tg545c)
Vlad, I unfortunately can't use your Mozregression tool. I am using Mozilla Firefox on a closed network that only limited applications are approved for use on. The only thing I can tell you is version 54 32bit has no problems with the VMware interface and 55.x.x all cause problems where you can't use the Webshere client, or HorizonView.
Flags: needinfo?(tg545c)
Unfortunately I can't test this as I do not have access to this software. VMWare cSphere appears to be some sort of cloud service and I guess VMWare used flash in the main browser interface. Unfortunate!

Can someone with access to this service try setting 'dom.ipc.plugins.asyncdrawing.enabled' to false through about:config, restart, and test to see if the input issue is address.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(tg545c)
I'm not sure what info you need. No, VMware vSphere is not a cloud service. It allows you to create a virtual environment with multiple systems on one server. Did flash disappear in version 55 of firefox?
Flags: needinfo?(tg545c)
I just downloaded and installed version 56 and it freezes up just like the previous versions. It looks like what ever the change was after version 54 is broke something with the interface when using vmware.
Hey Troy,

Can you try setting 'dom.ipc.plugins.asyncdrawing.enabled' to false in about:config and see if it addresses the issue?
Flags: needinfo?(tg545c)
I'll try that today and let you know what happens. Thanks.
Flags: needinfo?(tg545c)
It worked!!! Thank you. That change made all the difference.
Hey Troy, thanks for your help. FYI Adobe will release a new version of flash 27 in about a week. There's a good chance this will be fixed in the release, including cases where 'dom.ipc.plugins.asyncdrawing.enabled' is set to true. They have a beta out right now if you would like to test [1].

If you can't test using the beta,. I'd greatly appreciate you trying to release in a week or so to see if this issue is fixed.

Note, async drawing improves scrolling behavior and perf in Firefox so we want to get that turned on for everyone if we can.

[1] http://labs.adobe.com/technologies/flashruntimes/flashplayer/
Flags: needinfo?(tg545c)
Priority: -- → P2
I have encountered very similar problem with SeaMonkey 2.48 and 2.49.1 (worked in 2.46)

vsphere does not do anything when in foreground - when I switch tab there and back, everything I did shows as it should.
Ugly but a possible workaroung.

changing 'dom.ipc.plugins.asyncdrawing.enabled' did not help

Can you please check if this applies to you?
This started to work in SeaMonkey 2.49.3, even when dom.ipc.plugins.asyncdrawing.enabled is disabled.
Flags: needinfo?(tg545c)
You need to log in before you can comment on or make changes to this bug.