1.85% installer size (android-4-0-armv7-api15) regression on push 6df7dff00b94cf7232b7d507eee373fe6b0435f0 (Tue Aug 8 2017)

RESOLVED FIXED

Status

()

Firefox for Android
General
P1
normal
RESOLVED FIXED
2 months ago
22 days ago

People

(Reporter: wlach, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

unspecified
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+, firefox55 unaffected, firefox56 unaffected, firefox57 fixed, firefox58 fixed)

Details

Rather large increase in the .apk size from the new photon resources. Is there anything we can do to reduce/mitigate?

--

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=6df7dff00b94cf7232b7d507eee373fe6b0435f0

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  2%  installer size summary android-4-0-armv7-api15 opt      36,309,723.83 -> 36,980,326.50


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=8631

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Flags: needinfo?(topwu.tw)

Updated

2 months ago
Component: Untriaged → General
Product: Firefox → Firefox for Android

Comment 1

2 months ago
The root cause is that we've added some new images/icons in Nightly for new visual refresh, aka Photon. There are few things we can do to reduce the APK size:

1. Remove resources that are unused in new visual design, we use bug 1375351 to track this issue.
2. Compress images/icons, or maybe use vector drawable instead.
tracking-fennec: --- → ?

Updated

2 months ago
tracking-fennec: ? → +
Priority: -- → P1
Whiteboard: [FNC][SPT57.2][MVP]
Whiteboard: [FNC][SPT57.2][MVP] → [FNC][SPT57.3][BL]

Comment 2

a month ago
Hi :wlach,

Now Fennec apk size has been reduced to around 36,457,239. Can we close this bug now?

https://treeherder.mozilla.org/perf.html#/graphs?series=autoland,1545789,1,2
Flags: needinfo?(topwu.tw) → needinfo?(wlachance)
Whiteboard: [FNC][SPT57.3][BL]
This isn't a talos regression, but we can probably use the policy here as a guideline https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling

Is the improvement due to fixing the root cause in comment 1, or due to other, unrelated work? 

* If there are still mitigations for this regression that are possible and make sense to implement, we should probably keep this open (along with outlining what needs to be fixed). 
* If your recommendations in comment 1 were implemented and that's responsible for the improvement, then we can resolve as fixed.
* If there are no mitigations that make sense to implement and the regression is just something we have to accept, I would mark this as wontfix.
Status: NEW → RESOLVED
Last Resolved: 23 days ago
Flags: needinfo?(wlachance) → needinfo?(topwu.tw)
Resolution: --- → FIXED

Comment 4

23 days ago
We do still have some space to reduce the APK size and there is a meta bug 942609 that records all the related works.
Flags: needinfo?(topwu.tw)
(In reply to Jing-wei Wu [:jwu] from comment #4)
> We do still have some space to reduce the APK size and there is a meta bug
> 942609 that records all the related works.

Argh, I didn't actually mean to mark this as fixed. But if the issues here are being dealt with elsewhere, then let's just leave this be.
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: --- → fixed
status-firefox58: --- → fixed
You need to log in before you can comment on or make changes to this bug.