Closed Bug 1388700 Opened 2 years ago Closed 2 years ago

Increase horizontal margin/padding of bookmarks toolbar items

Categories

(Firefox :: Theme, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.2 - Aug 29
Tracking Status
firefox57 --- fixed

People

(Reporter: dao, Assigned: johannh)

References

Details

(Whiteboard: [reserve-photon-visual][p2])

Attachments

(1 file)

Spec: https://mozilla.invisionapp.com/share/MRBK1MZF7#/screens/237332831

This means that fewer items will fit on the toolbar, which has previously pissed off users. Stephen is aware of that but said we should still make the change to visually separate the items better.
Flags: qe-verify?
Priority: -- → P3
Flags: qe-verify? → qe-verify+
QA Contact: brindusa.tot
This will need to take compact mode into account, which should also be an adequate solution for users who are sensitive to fewer items fitting on the toolbar.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: P3 → P1
Iteration: --- → 57.2 - Aug 29
Comment on attachment 8897415 [details]
Bug 1388700 - Increase margin/padding of bookmarks toolbar items per Photon spec.

https://reviewboard.mozilla.org/r/168726/#review174454

The spec calls for 8px of padding at the start of the toolbar - currently there's only 4px. (And maybe we want to reduce this padding in compact mode?)
Attachment #8897415 - Flags: review?(nhnt11)
(In reply to Nihanth Subramanya [:nhnt11] from comment #3)
> Comment on attachment 8897415 [details]
> Bug 1388700 - Increase margin/padding of bookmarks toolbar items per Photon
> spec.
> 
> https://reviewboard.mozilla.org/r/168726/#review174454
> 
> The spec calls for 8px of padding at the start of the toolbar - currently
> there's only 4px.

That's bug 1388699.
Comment on attachment 8897415 [details]
Bug 1388700 - Increase margin/padding of bookmarks toolbar items per Photon spec.

https://reviewboard.mozilla.org/r/168726/#review174460
Attachment #8897415 - Flags: review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/41d701ddc958
Increase margin/padding of bookmarks toolbar items per Photon spec. r=nhnt11
Duplicate of this bug: 1389977
https://hg.mozilla.org/mozilla-central/rev/41d701ddc958
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I have reproduced this issue with nightly 57.0a1 (2017-08-09) on Windows 8, 64-bit.

Now seeing the Increased horizontal margin/padding of bookmarks toolbar items on latest nightly.


Build ID 	20170820100343
User Agent 	Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

[bugday-20170816]
Blocks: 1391625
No longer depends on: 1391625
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.