Add legal and telemetry fixes to Activity Stream (for Shield study)

RESOLVED FIXED in Firefox 56

Status

()

defect
RESOLVED FIXED
2 years ago
19 days ago

People

(Reporter: Mardak, Assigned: k88hudson)

Tracking

Trunk
Firefox 57
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox56 fixed, firefox57 fixed)

Details

(Whiteboard: [export])

User Story

https://github.com/mozilla/activity-stream/compare/firefox-56b1...firefox-56b4

Attachments

(2 attachments)

No description provided.
This WIP patch is the current state of exporting https://github.com/mozilla/activity-stream/compare/firefox-56b1...firefox-56 for k88hudson's reference.

She'll update with an actual patch that has the remaining items still waiting to land:
https://github.com/mozilla/activity-stream/labels/Release%20%2F%20Blocking
Assignee: nobody → khudson
Attachment #8897899 - Flags: review?(usarracini)
Comment on attachment 8897899 [details]
Bug 1389482 - Add legal and telemetry fixes to Activity Stream

https://reviewboard.mozilla.org/r/169174/#review174586

Thanks!
Attachment #8897899 - Flags: review?(usarracini) → review+
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c416d136f274
Add legal and telemetry fixes to Activity Stream r=ursula
Comment on attachment 8897899 [details]
Bug 1389482 - Add legal and telemetry fixes to Activity Stream

Approval Request Comment
[Feature/Bug causing the regression]: Critical telemetry for pocket was missing data, legal required us to remove certain icons and replace with screenshots.
[User impact if declined]: We can't ship our shield study which is critical for getting data in preparation for the 57 release
[Is this code covered by automated tests?]: Yes, tests are included in the Activity Stream repository
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: None, all changes are self-contained
[Is the change risky?]: No
[Why is the change risky/not risky?]: Activity stream is pref'd off by default for beta users, this will affect our shield study only
[String changes made/needed]: None
Attachment #8897899 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/c416d136f274
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8897899 [details]
Bug 1389482 - Add legal and telemetry fixes to Activity Stream

Fix we need for a shield study.
Attachment #8897899 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
We may not be able to land this for the beta 4 build.  If we do land this for a 2nd beta 4 build this afternoon I'll let you know.  Otherwise I think it is best to delay the shield study till next Tuesday for beta 5.
No longer blocks: 1387746
Blocks: 1391336
User Story: (updated)
(In reply to Kate Hudson :k88hudson from comment #6)
> [Is this code covered by automated tests?]: Yes, tests are included in the
> Activity Stream repository
> [Needs manual test from QE? If yes, steps to reproduce]: no

Based on Kate's assessment on manual testing needs and due to the fact that it has automated coverage, marking as qe-verify-.
Flags: qe-verify-
Whiteboard: [export]
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.