Closed Bug 1389883 Opened 2 years ago Closed 2 years ago

Thunderbird 56.0.beta2 Titlebar corrupted on MAC

Categories

(Thunderbird :: Theme, defect)

56 Branch
defect
Not set

Tracking

(thunderbird_esr52 unaffected, thunderbird56 fixed, thunderbird57 fixed)

RESOLVED FIXED
Thunderbird 57.0
Tracking Status
thunderbird_esr52 --- unaffected
thunderbird56 --- fixed
thunderbird57 --- fixed

People

(Reporter: Mozilla, Assigned: Paenglab)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170628075643

Steps to reproduce:

Default install


Actual results:

Inbox tab sits behind Maximize, Minimize, Full screen buttons


Expected results:

Inbox tab sits beside Maximize, Minimize, Full screen buttons
Flags: needinfo?(richard.marti)
Hmm, same as bug 1389110.

Ian, you upgraded from 55 to 56? I don't know of any change in this area. Could you try to go into the Preferences/Advanced/General and click on "Config Editor". Then in the search field enter 'drawintitlebar', now double click it. There should be now the titlebar with the controls above the tabs. Now double click the line again. Are the controls correctly separated again?

If not, could you try bug 1389110 comment 5?
Flags: needinfo?(richard.marti) → needinfo?(Mozilla)
I seem to recall that the problem occurred with version 55 also
Changing the value of "drawintitlebar" to false dropped the tabs below the window buttons
but changing it back to false caused the problem to re-occur.
Re: Bug 1389110 Comment 5
There was no localstore.json
Deleting xulstore.json made no difference when xulstore.json was recreated
Flags: needinfo?(Mozilla)
I don't see this problem, so it's a digging in the dark for me. Can you try to restart with Add-ons disabled (see help menu)? If this also doesn't help, can you start TB and then type CMD + SHIFT + J? Are there errors which could cause this issue? You can select and copy them.
Screenshot of error log
Starting safe mode makes no difference
Attached patch Bug1389883.patchSplinter Review
I was wrong with no change in this area. :(

Thanks to the console log I found a typo. Strange I don't see this on my Mac.

Ian, I started a try build. When it's finished, I'll give you the link to test it, okay? It will be a 57 Daily.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8896732 - Flags: review?(jorgk)
Blocks: 1385852
Comment on attachment 8896732 [details] [diff] [review]
Bug1389883.patch

I'll fix the commit message to:
Bug 1389883 - Bug 1385852 follow-up: Fix typo in Mac code part. r=jorgk

https://hg.mozilla.org/comm-central/rev/045fa1d535b5#l1.292
Attachment #8896732 - Flags: review?(jorgk) → review+
Component: Untriaged → Theme
Duplicate of this bug: 1389110
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/17dbc1c8a88b
Bug 1385852 follow-up: Fix typo in Mac code part. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 57.0
Comment on attachment 8896732 [details] [diff] [review]
Bug1389883.patch

Bug was opened from beta. If there is a plan for a beta, this should land also in beta.
Attachment #8896732 - Flags: approval-comm-beta?
Attachment #8896732 - Flags: approval-comm-beta? → approval-comm-beta+
I downloaded the file "thunderbird-57.0a1.en-US.mac.dmg" but could not open it.
It contained "daily.app" but macos (10.12.6) said the file was damaged and could not be opened
Flags: needinfo?(Mozilla)
Ian, thanks for trying it. The error message is misleading. The app isn't signed and macOS blocks it because of this. And I can't say how I resolved this to execute it anyway (Mac is not my main platform). It has something to do with the security settings. But with the error in the console it was clear what the problem was. I hope there will be another 56 beta that you can test.
at command prompt type:

sudo spctl --master-disable

This allows app from anywhere.

I ran your version and it does indeed work. I notice that the tab shape is now square.
Is that the default going forward or just a characteristic of this beta?
Thanks for testing. The square tabs will go live in TB 57 beta, you've been testing an "alpha" version, TB 57 Daily. That follows the UI restructuring in Firefox, please read here:
https://dolske.wordpress.com/2017/08/04/photon-engineering-newsletter-11/
You need to log in before you can comment on or make changes to this bug.