browser_getScreenshots.js is going to intermittently fail on Linux when Gecko 57 merges to Beta on 2017-09-20

VERIFIED FIXED in Firefox 57

Status

()

Firefox
Activity Streams: Newtab
VERIFIED FIXED
8 months ago
8 months ago

People

(Reporter: RyanVM, Assigned: Mardak)

Tracking

Trunk
Firefox 57
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified)

Details

(Reporter)

Description

8 months ago
Only appears to affect Linux32 debug, for reasons I can't explain beyond general "slow as molasses" reasons. Probably not worth spending much time on beyond skipping the test, but worth filing in case someone else has any insights.

https://treeherder.mozilla.org/logviewer.html#?job_id=122807510&repo=try

TEST-UNEXPECTED-FAIL | browser/extensions/activity-stream/test/functional/mochitest/browser_getScreenshots.js | Test timed out
(Assignee)

Comment 1

8 months ago
Was the original test disabled for various platforms/builds before? We might want to match some of that (except for the one caused by GCing the observer)
Flags: needinfo?(usarracini)
From what I remember, the original test (browser_PreviewProvider.js) was disabled on both linux and windows, both for frequent time outs (which I guess is the GCing the observer thing - bug 1343150)
Flags: needinfo?(usarracini)
(Reporter)

Comment 3

8 months ago
Latest set of Try pushes suggests this is just a frequent intermittent on Linux builds in general.
Summary: browser_getScreenshots.js is going to permafail on Linux32 debug when Gecko 57 merges to Beta on 2017-09-20 → browser_getScreenshots.js is going to intermittently fail on Linux when Gecko 57 merges to Beta on 2017-09-20
(Reporter)

Comment 4

8 months ago
Looks like this test got disabled across the board by bug 1389482. Not sure if we should bother leaving this open at this point.
Flags: needinfo?(edilee)
(Assignee)

Comment 5

8 months ago
k88hudson's turning off the test was somewhat accidental as part of how we were exporting beta changes to central for uplift. She also explicitly kept it disabled when exporting with bug 1391336.

I pushed some dumping to try to see where it's timing out:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=79a3da54fdf104853dc15af6ab72c9b4856f466f

Looking through bug 1343150 where this test came from, it looks like it was only intermittent on linux for a week per bug 1343150 comment 1 but then spiked from the GC weak reference change per bug 1343150 comment 3. We turned on the test after fixing the GC weak reference issue, so maybe it is indeed a linux specific slowness.
(Assignee)

Comment 6

8 months ago
(In reply to Ed Lee :Mardak from comment #5)
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=79a3da54fdf104853dc15af6ab72c9b4856f466f
Looks to be failing about 13% of the time on Linux32/64 debug or Stylo opt. But even on Linux32 debug, the test is normally finishing within 8 seconds max.

Maybe we'll just skip the test on linux for now.

I'll do a little bit more debugging as there might be an underlying failure to capture.. https://treeherder.mozilla.org/#/jobs?repo=try&revision=2c9a51970b59630da2fea9155097906c479eb2b2
(Assignee)

Comment 8

8 months ago
Fixed by https://github.com/mozilla/activity-stream/pull/3212 to be uplifted via bug 1392384.
Assignee: nobody → edilee
Blocks: 1392384
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
(Reporter)

Comment 9

8 months ago
I would prefer that we leave this open until the fix actually lands on mozilla-central.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

8 months ago
Fixed with https://hg.mozilla.org/mozilla-central/rev/f0d5588153e4
Status: REOPENED → RESOLVED
Last Resolved: 8 months ago8 months ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
(Assignee)

Updated

8 months ago
Blocks: 1394533
(Reporter)

Comment 11

8 months ago
Looks good AFAICT. I'll reopen if I see them again.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
You need to log in before you can comment on or make changes to this bug.