Closed Bug 1390051 Opened 3 years ago Closed 3 years ago

Port |Bug 1387803 - Remove the [deprecated] annotation from XPIDL| to C-C

Categories

(Thunderbird :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 57.0

People

(Reporter: jorgk-bmo, Assigned: jorgk-bmo)

References

Details

Attachments

(1 file)

Build busted this morning with:

xpidl.xpidl.IDLError: error: Unexpected attribute 'deprecated', ../../../dist/idl/nsIMsgHeaderParser.idl line 188:3

That's caused by
[deprecated] void parseHeadersWithArray(in wstring aLine, ...
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/baa8d52a254c
Port bug 1387803 to mailnews: remove use of [deprecated]. rs=bustage-fix
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 57.0
Comment on attachment 8896883 [details] [diff] [review]
1390051-deprecated.patch

Review of attachment 8896883 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks. Some of those functions are even unused so I'll remove them in a follow-up.
Attachment #8896883 - Flags: review+
Blocks: 1390337
You need to log in before you can comment on or make changes to this bug.