Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jlorenzo, Assigned: jlorenzo)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed, firefox57 fixed, firefox58 fixed)

Details

Attachments

(2 attachments)

First review came out of the Snap Store:

> desktop interfaces (unity7,x11) specified without a corresponding meta/gui/*.desktop
> file. If using snapcraft, please see https://snapcraft.io/docs/build-snaps/metadata#fixed-assets.
> Otherwise, please provide a desktop file in meta/gui/*.desktop (it should reference one of
> the 'apps' from your snapcraft/snap.yaml). lint-snap-v2_meta_gui_desktop
> 
> Please provide a desktop file and reupload.
> 
> Thank you for uploading a snap!
> 
> To check review details, go to https://dashboard.snapcraft.io/dev/snaps/8148/review/rev/1/
Blocks: 1390123
Comment on attachment 8896986 [details]
Bug 1390071 - Snap: Add required .desktop file

https://reviewboard.mozilla.org/r/168292/#review173478
Attachment #8896986 - Flags: review?(mtabara) → review+
Blocks: 1390152
This is a first revision. The desktop file come from the one they used at Ubuntu[1], so the Ubuntu people won't see any change. I manually replaced the variables because:
* MOZ_OFFICIAL_BRANDING => We currently only ship official builds
* @MOZ_DISPLAY_NAME@ => Same thing. I replaced it by "Firefox"
* @MOZ_APP_NAME@ => Thanks to our snapcraft.yaml[2], we know the command line will be "firefox" alone.

We should probably depend on the l10n toolchain. I filed bug 1390152 to keep track of this. 

[1] http://bazaar.launchpad.net/~mozillateam/firefox/firefox-trunk.head/view/head:/debian/firefox.desktop.in
[2] https://searchfox.org/mozilla-central/rev/6482c8a5fa5c7446e82ef187d1a1faff49e3379e/taskcluster/docker/firefox-snap/snapcraft.yaml.in#8
Assignee: nobody → jlorenzo
Blocks: snappy
No longer blocks: 1390152
I tested the patch locally with an ubuntu docker instance. I crafted the snap, and extracted it[1] and verified that the file:
> squashfs-root/meta/gui/firefox.desktop
existed.

snapcraft didn't report any additional error.

[1] unsquashfs firefox_*_amd64.snap
Landed on beta at: https://hg.mozilla.org/releases/mozilla-beta/rev/5f81b09432e0f866815ef111c2bc761128adcd53

Landing on central will follow after the next beta, if it worked.
For 56.0b3 build1 we got:
The path 'prime/distribution/firefox.desktop' set for 'desktop' in 'firefox' does not exist.

Full log - http://mozilla-release-logs.s3.amazonaws.com/mozilla-beta/firefox-56.0b3/build1/mozilla-beta_snap_generation-all-HgAhgaYZT4q1QV5uT-ApUg-0
Hmmm, that part was working for me on a local ubuntu docker image. I ran snapcraft v2.33. Maybe the real docker image is too old. I'm looking into this.
My previous guess was wrong. We use the latest snapcraft client, because we perform a `dist-upgrade` at each run.

That was working on another instance because I hadn't run `runme.sh` but copy and pasted some commands. I reproduce the error locally, on the real docker image, with `runme.sh`. This fixes the missing desktop file.
Attachment #8897786 - Flags: review?(mtabara)
Comment on attachment 8897786 [details] [diff] [review]
bug1390071-part2.patch

Review of attachment 8897786 [details] [diff] [review]:
-----------------------------------------------------------------

Sgtm. Sorry I didn't catch this in review either :(
Attachment #8897786 - Flags: review?(mtabara) → review+
Was fixed in comment 10.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Oops, I just realized that landed only on beta (56) back then. I should fix it in 57 too.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0741dc11bd62
Snap: Add required .desktop file r=mtabara
Blocks: 1401620
https://hg.mozilla.org/mozilla-central/rev/0741dc11bd62
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
See Also: → 296568
You need to log in before you can comment on or make changes to this bug.