Closed Bug 1390246 Opened 4 years ago Closed 4 years ago

Permafailing Mac Stylo /scroll-anchoring/anchoring-with-bounds-clamping.html | Anchoring combined with scroll bounds clamping in the document. - assert_equals: expected 100 but got 99

Categories

(Testing :: web-platform-tests, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: johannh)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:other][fixed by 1390448])

Filed by: wkocher [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=123013558&repo=autoland

https://queue.taskcluster.net/v1/task/D8pVmXbjRO2hUpTLjxrxpg/runs/0/artifacts/public/logs/live_backing.log

This started up with the landing of bug 1375335, went away when that got backed out, and returned when it relanded.

Tier-2, so not getting an immediate backout, but would be good to deal with soonish.
Flags: needinfo?(jhofmann)
Flags: needinfo?(jhofmann)
(I can try to dig about what can be going on here, but seems like a rounding issue, which would be somewhat unfortunate, because they're hard to track down... And I can't repro since I'm on Linux)
Flags: needinfo?(emilio+bugs)
To clarify, cc'ing you wasn't meant as "Emilio, fix it!", but rather as an FYI because we might get a chance to talk about this tomorrow. Sorry if that wasn't clear :)
Whiteboard: [stockwell needswork]
Surprisingly I did indeed change the tab bar height on OSX, so I'll fix that up in bug 1390448 which is very likely going to resolve this one.

(If anyone wants to fix the real issue they're still invited to do so ;)
Blocks: 1375335
Depends on: 1390448
No longer depends on: 1375335
Flags: needinfo?(jhofmann)
Duplicate of this bug: 1389382
Johann is on top of this, and I don't have the cycles to track the rounding error right now.
Flags: needinfo?(emilio+bugs)
Bug 1390448 should have "fixed" this.
Assignee: nobody → jhofmann
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Whiteboard: [stockwell needswork] → [stockwell needswork][fixed by 1390448]
Whiteboard: [stockwell needswork][fixed by 1390448] → [stockwell fixed:other][fixed by 1390448]
You need to log in before you can comment on or make changes to this bug.