Closed Bug 1390448 Opened 2 years ago Closed 2 years ago

Tab strip on OSX has moved up by 1px

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.2 - Aug 29
Tracking Status
firefox56 --- unaffected
firefox57 --- verified

People

(Reporter: johannh, Assigned: johannh)

References

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(1 file)

Blocks: 1390246
Iteration: --- → 57.2 - Aug 29
QA Contact: brindusa.tot
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
Blocks: 1390796
Comment on attachment 8897392 [details]
Bug 1390448 - Restore vertical margin calculation in browser-tabsintitlebar.js, add 1px to window control margin on Windows 10.

https://reviewboard.mozilla.org/r/168710/#review174452
Attachment #8897392 - Flags: review?(dao+bmo) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f7d05f4db14d
Restore vertical margin calculation in browser-tabsintitlebar.js, add 1px to window control margin on Windows 10. r=dao
https://hg.mozilla.org/mozilla-central/rev/f7d05f4db14d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I think we may need to revert this after bug 1390888.
Flags: needinfo?(jhofmann)
(In reply to Dão Gottwald [::dao] from comment #5)
> I think we may need to revert this after bug 1390888.

Yes, let's monitor that bug.

Here are the screenshots for this bug:

https://screenshots.mattn.ca/compare/?oldProject=mozilla-central&oldRev=833f84d0d5c729054a3aa8b3f34735f56fe6436b&newProject=mozilla-central&newRev=1d38626ba9686d119e489db538ce84f8f9854217
we have a perf improvement with this bug (which seems to fix bug 1390796):
== Change summary for alert #8829 (as of August 16 2017 13:48 UTC) ==

Improvements:

  3%  tresize windows7-32 opt e10s     12.00 -> 11.58

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=8829
Quite interesting.
Actually, looking at the results on central, I think this is exactly what we want. I'll check with shorlander once this hits Nightly.
I think we can leave this as it is, bug 1391328 will remove the top border on OSX and that is how it's supposed to look then.
Flags: needinfo?(jhofmann)
QA Contact: brindusa.tot → ovidiu.boca
I tested this on Mac OS X 10.10 with FF 57.0b9 and I can't reproduce this issue. I will mark as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.