Closed Bug 1391141 Opened 2 years ago Closed 2 years ago

stylo: accessible/tests/mochitest/events/test_docload.html crashes on Windows debug build with "Assertion failure: cachedBinding == aProtoBinding"

Categories

(Core :: CSS Parsing and Computation, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: xidorn, Assigned: xidorn)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

accessible/tests/mochitest/events/test_docload.html is currently disabled for bug 1390409, but actually there is another issue with this test that it crashes on Windows debug build with assertion "Assertion failure: cachedBinding == aProtoBinding".

This is because the test contains "about:" and "about:buildconfig" page, which uses Gecko backend currently.

After bug 1390409 gets fixed, we would still need to disable that test on Windows debug because of this.

One solution to fix this issue would be to use Stylo backend for the above-mentioned two about: pages. Those pages seem to be totally fine with Stylo. But this may not be worth doing at all.

We can probably just wait until we enable stylo for all about: pages.
Priority: -- → P4
Duplicate of this bug: 1394317
Depends on: 1400540
Comment on attachment 8915814 [details]
Bug 1391141 - Reenable test_docload.html on stylo Windows.

https://reviewboard.mozilla.org/r/187028/#review192086
Comment on attachment 8915814 [details]
Bug 1391141 - Reenable test_docload.html on stylo Windows.

https://reviewboard.mozilla.org/r/187030/#review192088
Attachment #8915814 - Flags: review+
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/32a477bbaf1c
Reenable test_docload.html on stylo Windows. r=xidorn
https://hg.mozilla.org/mozilla-central/rev/32a477bbaf1c
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Assignee: nobody → xidorn+moz
Whiteboard: [checkin-needed-beta]
https://hg.mozilla.org/releases/mozilla-beta/rev/f7fd0e6a425a
Flags: in-testsuite+
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.