Closed Bug 1394317 Opened 2 years ago Closed 2 years ago

stylo: accessible/tests/mochitest/events/test_docload.html crashes with "Assertion failure: cachedBinding == aProtoBinding" on Windows debug

Categories

(Core :: CSS Parsing and Computation, defect, P4)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1391141
Tracking Status
firefox57 --- affected

People

(Reporter: xidorn, Unassigned)

References

(Blocks 1 open bug)

Details

Copy from bug 1383845 comment 8:

So at least in accessible/tests/mochitest/events/test_docload.html, it seems the issue is that, cachedBinding uses Servo backend, while aProtoBinding uses Gecko backend, which causes this inconsistency. And in this case, the binding in question is the resizer.

For test_docload.html, this is probably because of the "about:" and "about:buildconfig" pages in iframes, which may still using Gecko backend. This is inevitable for now given we don't really want to enable stylo on about pages at the moment (bug 1376805), although I guess "about:" and "about:buildconfig" may actually be fine to use stylo.

All reftests and crashtests which have this bug annotated involves some kind of iframe (or frame) with either data URI or operation in empty documents, which, I suspect, should have been fixed in bug 1384162.

I have no idea why this happens on Windows only, though. It seems to me this really should be a problem across all platforms.
Why did I file two identical bugs :/
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1391141
You need to log in before you can comment on or make changes to this bug.