I need help about New UI (Photon) due to upgrade from Firefox56 to Nightly57

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
11 months ago
11 months ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({dupeme, ux-discovery})

57 Branch
x86_64
Windows 10
dupeme, ux-discovery
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
Because. some menus and toolbar buttons are gone and rearranged/relocated to another place.
(Subscribe, Share This Page, Forget button)
(Page actions, Library, More)

I could not find any help and tutorial about UI change.
(Reporter)

Updated

11 months ago
Whiteboard: [photon-structure][DUPEME]
(Reporter)

Updated

11 months ago
Keywords: ux-discovery

Updated

11 months ago
Whiteboard: [photon-structure][DUPEME] → [photon-structure] [triage] [DUPEME]

Updated

11 months ago
Component: Untriaged → General

Comment 1

11 months ago
(In reply to Alice0775 White from comment #0)
> Because. some menus and toolbar buttons are gone and rearranged/relocated to
> another place.
> (Subscribe, Share This Page, Forget button)

Share this page was removed independently from photon - see https://bugzilla.mozilla.org/show_bug.cgi?id=1388902 .

We haven't touched the forget button or subscribe (though there's a plan for the latter, see https://bugzilla.mozilla.org/show_bug.cgi?id=1375687 ), so I'm not sure what you mean. We moved anything you might have added to the hamburger panel into the overflow panel and replaced the bookmarks menu button with the library button (which has an entry to get the bookmarks menu back!), but otherwise I don't think much changed. Can you elaborate on what you think changed about subscribe/forget ?

> I could not find any help and tutorial about UI change.

This is ultimately an onboarding issue. Verdi, what are the plans for users who upgrade?
Flags: needinfo?(mverdi)
Flags: needinfo?(alice0775)
Keywords: dupeme
Whiteboard: [photon-structure] [triage] [DUPEME] → [photon-onboarding][triage]
(Reporter)

Updated

11 months ago
Depends on: 1391601

Updated

11 months ago
Duplicate of this bug: 1391601
(Reporter)

Comment 3

11 months ago
> We moved anything you might have added to the hamburger panel into the overflow panel.

No. 
At the present moment, these added buttons are gone. Overflowed panel is empty after upgrade to Nightly57.0a1.
Flags: needinfo?(alice0775)
(Reporter)

Comment 4

11 months ago
I can not find Forget button too.

Comment 5

11 months ago
(In reply to Alice0775 White from comment #4)
> I can not find Forget button too.

It's available in customize mode for me. The icon has changed, but it's there...

(In reply to Alice0775 White from comment #3)
> > We moved anything you might have added to the hamburger panel into the overflow panel.
> 
> No. 
> At the present moment, these added buttons are gone. Overflowed panel is
> empty after upgrade to Nightly57.0a1.

I can reproduce this. I'll investigate and file a separate bug once I know why the migration code is not working - but it was written in bug 1354117 and seemed to work then. :-\

Updated

11 months ago
Depends on: 1391616

Comment 6

11 months ago
When you update to 57 there will be a tour that includes sections about the Library button, the Address Bar, Screenshots (which will be in page actions) and Customize mode.
Flags: needinfo?(mverdi)
(Reporter)

Comment 7

11 months ago
may be tour would not show, if set "When Firefox starts: Show my windows and tabs from last time".

Anyway, New UI is complicated for me after upgrade to 57 from 56.
I have to find out where the existing UI is :(
(Reporter)

Comment 8

11 months ago
Okay, I must use legacy Menubar.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
status-firefox57: affected → ---
Resolution: --- → WONTFIX

Comment 9

11 months ago
remove whiteboard tag due to its WONTFIX
Whiteboard: [photon-onboarding][triage]
You need to log in before you can comment on or make changes to this bug.