Open Bug 1392929 Opened 2 years ago Updated 2 years ago

Port Bug 886907 [Remove old synchronous contentPrefService] to SeaMonkey

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.54 Branch
defect
Not set

Tracking

(seamonkey2.54 affected, seamonkey2.55 affected)

Tracking Status
seamonkey2.54 --- affected
seamonkey2.55 --- affected

People

(Reporter: domfillon, Unassigned)

References

(Blocks 1 open bug)

Details

User Story

Text / Font sizing not available anymore.
Data Manager broken too.
Back/Forward buttons broken

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0 SeaMonkey/2.54a1 Lightning/5.9a1
Build ID: 20170822044702

Steps to reproduce:

Testing with SeaMonkey nightly (User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0 SeaMonkey/2.54a1
Build identifier: 20170822044702)
The text sizing controls are not present, not effective (Ctrl +, Ctrl -)



Actual results:

no possibility to increase / decrease font size in browser window.


Expected results:

Increase / decrease font size was still working on builds 20170813 (Win32 and Win64)
The browser menu View does not show the usual Ctrl+ / Ctrl - (increase / decrease font).
Regression between 20170813 and 20170822
Some more details:
- The problem is still there with add-ons disabled.
- The browser menu under "View" is partially there for CTRL+ and CTRL-, but not effective, either in normal or add-ons disabled modes.
Status: UNCONFIRMED → NEW
User Story: (updated)
Ever confirmed: true
Summary: Text / Font sizing not available anymore (regression) → Port Bug 886907 [Remove old synchronous contentPrefService] to SeaMonkey
Assignee: nobody → wgianopoulos
Status: NEW → ASSIGNED
As the comment says. Just a quick hack till Bill is ready with a patch. Unbreaks the browser but zoom handling/setting will likely be not ok because the old sync apis are still used.
User Story: (updated)
Duplicate of this bug: 1397186
Duplicate of this bug: 1397197
Duplicate of this bug: 1399355
Assignee: wgianopoulos → nobody
Status: ASSIGNED → NEW
Comment on attachment 8903585 [details] [diff] [review]
1392929-thisisnotafix.patch

This bug breaks the browser badly. I suggest putting in the interim hacky patch till the real patch is ready. Back Forward works again with it and most fuctionality too.
Attachment #8903585 - Flags: review?(iann_bugzilla)
I second that. I am using the interim patch and the only inconvenience is the lack of automatic password provision. BTW, the ancient chrome://passwordmgr/content/passwordManager.xul is infinitely more performant than the 'data manager' provided through the menus, even when this works (which it doesn't at the moment).
David, if you compile SeaMonkey yourself also put the patch for Bug 1394101 in and Data Manager should work again for everything but content prefs.
Comment on attachment 8903585 [details] [diff] [review]
1392929-thisisnotafix.patch

r=me for the sticking plaster
Attachment #8903585 - Flags: review?(iann_bugzilla) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/0ca324fbb106
Temporary Fix for contentPrefService removal. r=IanN
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Comment on attachment 8903585 [details] [diff] [review]
1392929-thisisnotafix.patch

Working to fix up 2.54 now and this would help me there too.
Attachment #8903585 - Flags: approval-comm-beta?
Comment on attachment 8903585 [details] [diff] [review]
1392929-thisisnotafix.patch

a=me
Attachment #8903585 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.