Stop changing the Go button's color on hover

RESOLVED FIXED in Firefox 57

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ashish, Assigned: akriti.v10, Mentored)

Tracking

(Blocks 1 bug, {good-first-bug})

57 Branch
Firefox 57
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [reserve-photon-visual][lang=css])

Attachments

(1 attachment)

Reporter

Description

2 years ago
The Go button on the awesomebar, updated in Bug 1391395, has a green hover color using the default theme. Per the Photon color guidelines[1], accents color for highlighting buttons should be from the blue palette. Thanks!


[1] http://design.firefox.com/photon/visual/color.html
Stephen, should we change this color?
Flags: needinfo?(shorlander)
Whiteboard: [photon-visual][triage]
There is no special state we need to convey for this. We should just use the same hover / active attribute as the rest of the icons in that area — Grey. Green was a hold over from the Blue / Red / Green when it was the Reload / Stop / Go button.
Flags: needinfo?(shorlander)
So we just need to remove this rule: http://searchfox.org/mozilla-central/rev/4d8e389498a08668cce9ebf6232cc96be178c3e4/browser/themes/shared/urlbar-searchbar.inc.css#186-191
Mentor: dao+bmo
Keywords: good-first-bug
Priority: -- → P4
Summary: Change hover color for awesomebar Go button to blue → Stop changing the Go button's color on hover
Whiteboard: [photon-visual][triage] → [reserve-photon-visual][lang=css]
Assignee

Comment 4

2 years ago
Hi, can i work on this bug?
(In reply to akriti verma from comment #4)
> Hi, can i work on this bug?

Sure. Do you have the source code and have you built Firefox yet?
Comment hidden (mozreview-request)

Comment 7

2 years ago
mozreview-review
Comment on attachment 8905570 [details]
Bug 1394137 - Stop changing the Go button's color on hover

https://reviewboard.mozilla.org/r/177376/#review182370

Looks good. Thanks!
Attachment #8905570 - Flags: review+

Comment 8

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/26d748e59642
Stop changing the Go button's color on hover r=dao
Assignee: nobody → akriti.v10
Flags: qe-verify-
Status: NEW → ASSIGNED
Priority: P4 → P1
https://hg.mozilla.org/mozilla-central/rev/26d748e59642
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Iteration: --- → 57.3 - Sep 19

Updated

2 years ago
Duplicate of this bug: 1397451
You need to log in before you can comment on or make changes to this bug.