"Customize" pane missing "fixed space" & "spacer" items

RESOLVED DUPLICATE of bug 985308

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 985308
6 months ago
6 months ago

People

(Reporter: bobgranet, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170825011442

Steps to reproduce:

View -> Toolbars -> Customize ...


Actual results:

The customize pane, displaying these icons is shown:

  https://i.imgur.com/YZnfXff.png

Note there's a 'flexible space', but no 'fixed space' or 'spacer' ( "|" ).
(Reporter)

Comment 1

6 months ago
There's a similar request

 [cust] need a toolbar spacer and spring spacer for customize
  https://bugzilla.mozilla.org/show_bug.cgi?id=162036

from ~15 years ago that was fixed.

Afaict, the 'spacer' & 'space' have been available since ... until recently.
(Reporter)

Updated

6 months ago
Component: Untriaged → Toolbars and Customization
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

6 months ago
OS: Linux → All
Hardware: x86_64 → All
Summary: FF Dev v56 'Customize' pane missing toolbar-draggable 'fixed space' & 'spacer' items → "Customize" pane missing "fixed space" & "spacer" items
(Reporter)

Comment 2

6 months ago
I do find references in

	firefox/omni.ja

	...
		toolbarseparator {
		  -moz-binding: url("chrome://global/content/bindings/toolbar.xml#toolbardecoration");
		}

		toolbarspacer {
		  -moz-binding: url("chrome://global/content/bindings/toolbar.xml#toolbardecoration");
		}

		toolbarspring {
		  -moz-binding: url("chrome://global/content/bindings/toolbar.xml#toolbardecoration");
		  -moz-box-flex: 1000;
		}
	...

Updated

6 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 985308
You need to log in before you can comment on or make changes to this bug.