Closed Bug 1394709 Opened 2 years ago Closed Last year

Add Microsoft JhengHei to font.name-list.sans-serif.zh-TW

Categories

(Core :: Layout: Text and Fonts, enhancement, P3)

Unspecified
Windows
enhancement

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: m_kato, Assigned: m_kato)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

http://searchfox.org/mozilla-central/rev/cd82cacec2cf734768827ff85ba2dba90a534c5e/modules/libpref/init/all.js#3721

We don't have Microsoft JhengHei entry in zh-TW of sans-serif.  Since we should add this to this entry.  Since Microsoft JhengHei is one of default font of zh-TW.
Tim, I would like to get feedback this changes from TPE team.  Who is best person?
Flags: needinfo?(timdream)
Loop the localization/local community should be sufficient.

PS what do you think about bug 1350766? Do you think we'll need to some feedback too?
Flags: needinfo?(timdream) → needinfo?(petercpg)
OS: Unspecified → Windows
The reason we did not put Microsoft Jhenghei into font.name-list.*.zh-TW is there are known bugs like redundant spaces after some characters, and overlapping issues when rotated. [1] [2]

However, I still support this change.


[1] https://support.microsoft.com/zh-tw/help/2710845, 'Microsoft suggested not to use MSJH to display Chinese temporarily'
[2] https://zh.wikipedia.org/wiki/%E5%BE%AE%E8%BB%9F%E6%AD%A3%E9%BB%91%E9%AB%94
Flags: needinfo?(petercpg)
(In reply to Peter Pin-Guang Chen [:petercpg] (MozTW.org) from comment #3)
> The reason we did not put Microsoft Jhenghei into font.name-list.*.zh-TW is
> there are known bugs like redundant spaces after some characters, and
> overlapping issues when rotated. [1] [2]
> 
> However, I still support this change.
> 
> 
> [1] https://support.microsoft.com/zh-tw/help/2710845, 'Microsoft suggested
> not to use MSJH to display Chinese temporarily'
> [2]
> https://zh.wikipedia.org/wiki/%E5%BE%AE%E8%BB%9F%E6%AD%A3%E9%BB%91%E9%AB%94

I see.  But Chrome and Edge seem to change to Microsoft Jhenghei as default font with this bug.
(In reply to Makoto Kato [:m_kato] from comment #4)
> (In reply to Peter Pin-Guang Chen [:petercpg] (MozTW.org) from comment #3)
> > The reason we did not put Microsoft Jhenghei into font.name-list.*.zh-TW is
> > there are known bugs like redundant spaces after some characters, and
> > overlapping issues when rotated. [1] [2]
> > 
> > However, I still support this change.
> > 
> > 
> > [1] https://support.microsoft.com/zh-tw/help/2710845, 'Microsoft suggested
> > not to use MSJH to display Chinese temporarily'
> > [2]
> > https://zh.wikipedia.org/wiki/%E5%BE%AE%E8%BB%9F%E6%AD%A3%E9%BB%91%E9%AB%94
> 
> I see.  But Chrome and Edge seem to change to Microsoft Jhenghei as default
> font with this bug.

Yep, bugs are reproducible on Fx/GC/Edge on my Win 10 PC so I'm good with this. Thank you Kato-san.
Priority: -- → P3
Assignee: nobody → m_kato
Is it possible to merge the above patch?
Flags: needinfo?(m_kato)
(In reply to Krasnaya Ploshchad’ from comment #9)
> Is it possible to merge the above patch?

Yes, https://treeherder.mozilla.org/#/jobs?repo=try&author=m_kato@ga2.so-net.ne.jp seems to be passed.
Flags: needinfo?(m_kato)
Comment on attachment 8952957 [details] [diff] [review]
Add Microsoft JhengHei to font.name-list.sans-serif.zh-TW for Nightly

Default Traditional Chinese font of Chrome and Edge on Windows are Microsoft JhengHei now, so we should change it to same font that supports ClearType.

Also, this font has a bug (see comment #3 and comment #4), but Edge and Chrome are same result for this.
Attachment #8952957 - Flags: review?(jfkthame)
Attachment #8952957 - Flags: review?(jfkthame) → review+
With the current patch restricting it to Nightly/Early-Beta only, we'll presumably want a followup to let it ride the release train fairly soon, unless unexpected problems (beyond the already-known bugs) show up.
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a3947599d1af
Add Microsoft JhengHei to font.name-list.sans-serif.zh-TW. r=jfkthame
https://hg.mozilla.org/mozilla-central/rev/a3947599d1af
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
See Also: → 1496790
Depends on: 1514112
Depends on: 1517937
You need to log in before you can comment on or make changes to this bug.