Closed Bug 1398142 Opened 2 years ago Closed 2 years ago

Pinned tabs are sometimes overlapping and cluttered after restoring a session

Categories

(Firefox :: Tabbed Browser, defect, P1)

57 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 + fixed
firefox58 --- fixed

People

(Reporter: gueroJeff, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(3 files)

What is happening:

Space for each pinned tab is crowding and overlapping their neighboring pinned tabs. 

This is on today's Nightly, 57.0a1 (2017-09-08) (64-bit), on Mac OS.

What is expected:

Pinned tabs should maintain boundaries that respect the space of their neighboring pinned tabs and not display those boundaries over pinned tab icons.

Steps to reproduce:

1) Switch to the light theme.
2) Pin three or more tabs to the tab bar (?).
3) Hover over each pinned tab to see the crowding and overlaps.
Works for me. Can you reproduce in a clean profile? Any add-ons in this profile? Does it matter which tabs you pin? Do you maybe need more than 3 to reproduce?
Flags: needinfo?(jbeatty)
I haven't been able to reproduce. Seems to have been fixed. Thanks
Flags: needinfo?(jbeatty)
Resolving per comment #2.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Today I restored a session consisting of two windows that had only recently been upgraded to 57 for the first time and the first window's pinned tabs were overlapping. #tabbrowser-tab margin-inline-start only gave room for 24px wide pinned tabs when it should have been 40px. I have been unable to reproduce it after further restarts.
Status: RESOLVED → REOPENED
Keywords: regression
Resolution: WORKSFORME → ---
Version: unspecified → 57 Branch
(In reply to Kestrel from comment #4)
> Created attachment 8910702 [details]
> pinned-tabs-squashed.png
> 
> Today I restored a session consisting of two windows that had only recently
> been upgraded to 57 for the first time and the first window's pinned tabs
> were overlapping. #tabbrowser-tab margin-inline-start only gave room for
> 24px wide pinned tabs when it should have been 40px. I have been unable to
> reproduce it after further restarts.

Feels like there's a race condition here. Maybe folks on the visual team who know about this bit of the tabstrip implementation have some idea of how to move forward here.
Whiteboard: [photon-visual][triage]
See Also: → 1396833
Whiteboard: [photon-visual][triage]
[Tracking Requested - why for this release]:

Proactively requesting tracking, but I'm afraid we'll need more information -- steps to reproduce or a regression range -- for this bug to be actionable.
Tracked for 57 for now, beta57 will be at 100% starting today, let's wait see whether this is a widespread issue or not.
Seems to be quite a rare bug, I have been able to reproduce it a few times but without a reliable STR. 

It only happens when:
1. Upgrading a profile from FF56 to FF57 for the first time.
2. Session has more than one window.
3. First window has pinned tabs and an overflowing tab strip.
Andrei, can your team have a look to try to reproduce with Kestrel's suggestions in comment 8? Thanks.
Flags: needinfo?(andrei.vaida)
I tried to reproduce this bug using Windows 10x64, Ubuntu 16.04x64 and Mac OS 10.11. 

I used two methods:

  1. Update from beta 56 to beta 57.
  2. Update from Nightly 56 to Nightly 58 (unfortunately I couldn't stop the update at 57, so I am not sure if the result from this method is relevant).

In both cases I used the default and the light theme, but I couldn't reproduce it. The tabs I pinned remained the same. They weren't overlapping. 

Did I miss something?
Flags: needinfo?(andrei.vaida)
Priority: -- → P2
Duplicate of this bug: 1409066
I believe bug 1392157 regressed this.
Assignee: nobody → dao+bmo
Blocks: 1392157
Status: REOPENED → ASSIGNED
Priority: P2 → P1
Summary: Pinned tabs are overlapping and cluttered → Pinned tabs are sometimes overlapping and cluttered after restoring a session
Comment on attachment 8920544 [details]
Bug 1398142 - Always specify .tab-throbber size so that pinned tabs can be positioned correctly before the session has been restored.

https://reviewboard.mozilla.org/r/191550/#review197250
Attachment #8920544 - Flags: review?(jaws) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/609a1d5781e2
Always specify .tab-throbber size so that pinned tabs can be positioned correctly before the session has been restored. r=jaws
https://hg.mozilla.org/mozilla-central/rev/609a1d5781e2
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8920544 [details]
Bug 1398142 - Always specify .tab-throbber size so that pinned tabs can be positioned correctly before the session has been restored.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1392157
[User impact if declined]: see comment 0
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple fix
[String changes made/needed]: /
Attachment #8920544 - Flags: approval-mozilla-beta?
Comment on attachment 8920544 [details]
Bug 1398142 - Always specify .tab-throbber size so that pinned tabs can be positioned correctly before the session has been restored.

Low risk fix, the squished pinned tabs look bad, fixing it seems like a good idea,  Beta57+
Attachment #8920544 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.