Closed Bug 1398481 Opened 4 years ago Closed 2 months ago

WebExtensions - Embedded add-on options page does not zoom when Add-ons Manager (about:addons) page is zoomed

Categories

(Toolkit :: Add-ons Manager, defect, P5)

56 Branch
defect

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox57 --- wontfix
firefox86 --- fixed

People

(Reporter: dw-dev, Assigned: emilio)

References

Details

Attachments

(6 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170809080026

Steps to reproduce:

In Firefox 56 or Firefox 57:

1. Select Tools > Add-ons.
2. Select Extensions tab.
3. Click Options button of any WebExtensions add-on (e.g. Print Edit WE)
4. Increase the zoom level to 200%.



Actual results:

The options dialog (embedded options page) for Print Edit WE does not increase in size (is not zoomed).


Expected results:

The options dialog (embedded options page) for Print Edit WE should increase in size (should be zoomed).
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Priority: -- → P5
It's unfortunate that this was marked as "wontfix". Even though the issue is specifically about extension options, not fixing zoom issues means that users with low vision may have a difficult time using Firefox.
(In reply to Marcy Sutton from comment #1)
> It's unfortunate that this was marked as "wontfix".

It was marked as wontfix for Firefox 57 which shipped more than a year ago.  The bug is still open, albeit not a high priority.
Duplicate of this bug: 1514816
Duplicate of this bug: 1571614
Duplicate of this bug: 1595864
Duplicate of this bug: 1500661
See Also: → 1647056
See Also: → 1681810

Emilio, do you know how we might get the extension's browser here to zoom with the page zoom? This bug has a couple other attached to it and I'm somewhat curious if zooming the extension's browser would help fix them

Flags: needinfo?(emilio)

Can you elaborate what you mean? The extension browser seems zoomed in / out. I was using the tree style tabs option page for reference, and text becomes larger / smaller as I zoom in and out.

Flags: needinfo?(emilio) → needinfo?(mstriemer)
Attached image 100%.jpg

100% scaling for TST from about:addons.

Attached image 200%.jpg

200% scaling for TST from about:addons.

Emilio, I think these screenshots show the situation. You can see parts of the screen are being scaled properly, but others are not. If you click on the "Open this options page in more wide space", that page properly responds to scaling. (Ex: moz-extension://6939839e-4af5-451a-a51f-c1c4fdc46bc4/options/options.html#!)

Huh, odd. I do see those contents scaled here... Are you on nightly as well?

No, sorry ... I am on FF83.

It'd be good to check if this is fixed on Nightly for you too or if this is somehow OS-specific or something. If you could try a build from https://nightly.mozilla.org it'd be great, but no worries if not, I can check on a Windows machine next week.

Here's an example zooming from macOS nightly. The page is zooming but the content provided by the extension here doesn't grow. The text inputs are the same size at all zoom levels.

Flags: needinfo?(mstriemer)

I fired up Windows Sandbox, installed Nightly (85.0a1 (2020-12-12) (64-bit)), installed TST ... still not working.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Emilio, looks like Michael and I aren't seeing the zoomed content within the Preferences/Options tab here. It looks like in your screenshot it isn't zoomed as well, the text in the extension provided content in the Preferences tab appears to be its regular size.

Any idea how we might go about fixing this?

Flags: needinfo?(emilio)

So the text in my page is definitely zoomed, but I think I figured out why. I was zooming with Ctrl+Mousewheel when pointing to the settings page.

D'oh. I can repro the issue when zooming with Ctrl+/Ctrl-.

Full zoom causes the window to resize, so we use this to detect the
change. We could probably listen to the FullZoomChanged event on
embedder browser or something, but that seemed a bit more complicated.

Assignee: nobody → emilio
Status: NEW → ASSIGNED

Something like that?

Flags: needinfo?(emilio)
Attachment #9193107 - Attachment description: Bug 1398481 - Propagate full zoom to add-on options browser. r=mstriemer → Bug 1398481 - Propagate zooms to add-on options browser. r=mstriemer

Actually to handle text zoom we need to do the hard thing, so did that.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71e96c86c84c
Propagate zooms to add-on options browser. r=mstriemer
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
You need to log in before you can comment on or make changes to this bug.