Closed Bug 1399378 Opened 2 years ago Closed 2 years ago

(photon) update the logo for 57 beta / release

Categories

(Firefox for Android :: General, defect, P1, major)

defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- fixed

People

(Reporter: wehuang, Assigned: jwu)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [FNC][SPT58.1][INT])

Attachments

(3 files)

Per the conclusion from Product, this is in order to align with Firefox desktop.
Joe, please let us know once the icon is ready for land, thanks.
Blocks: 1396741
Flags: needinfo?(jcheng)
Flags: needinfo?(jcheng) → needinfo?(shorlander)
Severity: normal → major
Priority: -- → P1
QA Contact: ioana.chiorean
This updates the branding assets.
Flags: needinfo?(shorlander) → needinfo?(whuang)
Flags: needinfo?(whuang) → needinfo?(wehuang)
Per Eric's reply in the offline mail tread, we should land it on Sept 26 or later, from the marketing perspective.

58.2 MVP (if not yet done then).
Flags: needinfo?(wehuang)
Flags: needinfo?(jcheng)
Flags: needinfo?(cnevinchen)
Does this cover the implementation of adaptive icons for Android Oreo and newer ?
Hi Stephen
Will you land this patch or I should do it?

btw, we also need to update images for firstrun_welcome.png for different channels.
Flags: needinfo?(shorlander)
(In reply to Nevin Chen [:nechen] from comment #5)
> Hi Stephen
> Will you land this patch or I should do it?

Will you please? I don't think I have landing privileges anymore. 

> btw, we also need to update images for firstrun_welcome.png for different
> channels.

The only thing I found for firstun_welcome.png is this: http://searchfox.org/mozilla-central/source/mobile/android/app/src/main/res/drawable-nodpi/firstrun_welcome.png
Flags: needinfo?(shorlander)
Ok(In reply to Stephen Horlander [:shorlander] from comment #6)
> Will you please? I don't think I have landing privileges anymore. 
> 
Thanks!

> The only thing I found for firstun_welcome.png is this:
> http://searchfox.org/mozilla-central/source/mobile/android/app/src/main/res/
> drawable-nodpi/firstrun_welcome.png

Yes. It should also be logo images. And it needs to respect channels. I'll ni Carol for those in bug 1402882
Flags: needinfo?(cnevinchen)
Hi Stephen,

:carol also provide us a set of beta/official logo icons, I cannot tell the difference between yours, but since the overall file size she provides are smaller, I would like to use her icon set. Hope you don't mind.
Assignee: nobody → topwu.tw
Comment on attachment 8913120 [details]
Bug 1399378 - Update Fennec logo icons for 57 beta/release.

https://reviewboard.mozilla.org/r/184534/#review189684
Attachment #8913120 - Flags: review?(cnevinchen) → review+
Pushed by topwu.tw@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/65ea1109e3ef
Update Fennec logo icons for 57 beta/release. r=nechen
Could you please fill an uplift request to beta asap? thanks
Flags: needinfo?(topwu.tw)
Comment on attachment 8913120 [details]
Bug 1399378 - Update Fennec logo icons for 57 beta/release.

Approval Request Comment
[Feature/Bug causing the regression]:
New logo icons for 57 beta/release

[User impact if declined]:
No new logo on 57

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
Not yet

[Needs manual test from QE? If yes, steps to reproduce]: 
Yes, check the logo icons are changed and are same as desktop.

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
This patch only change images.

[String changes made/needed]:
No
Flags: needinfo?(topwu.tw)
Attachment #8913120 - Flags: approval-mozilla-beta?
Comment on attachment 8913120 [details]
Bug 1399378 - Update Fennec logo icons for 57 beta/release.

Thanks.
Should be in 57b4, gtb later today
Attachment #8913120 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/mozilla-central/rev/65ea1109e3ef
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Verified the icon changes on Beta 57.0b4.
Devices:
LG Nexus 5 (Android 6.0.1)
Huawei MediaPad M2 (Android 5.1.1)
Status: RESOLVED → VERIFIED
Attached image screenshot
I already said this in bug 1388679 but it's also true for Beta - you forgot the Firefox logo on the about screen.
Soren, you should open a new bug for that. Thanks
Whiteboard: [FNC][SPT58.1][INT]
You need to log in before you can comment on or make changes to this bug.