Closed Bug 1400605 Opened 5 years ago Closed 5 years ago

Crash in java.lang.NullPointerException: at org.mozilla.gecko.webapps.WebAppActivity.updateTaskAndStatusBar(WebAppActivity.java)

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect, P1)

57 Branch
Unspecified
Android
defect

Tracking

(fennec+, firefox56 unaffected, firefox57 wontfix, firefox58 verified)

VERIFIED FIXED
Firefox 58
Tracking Status
fennec + ---
firefox56 --- unaffected
firefox57 --- wontfix
firefox58 --- verified

People

(Reporter: jovan.gerodetti, Assigned: droeh)

References

Details

(Keywords: regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-440a9353-619b-4419-b99c-a5c850170916.
=============================================================
Assignee: nobody → droeh
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Please set a priority.
Flags: needinfo?(droeh)
Severity: critical → normal
Flags: needinfo?(droeh)
Priority: -- → P3
Too late for 57, very low volume crash but there are a few in 58.
Device:
 - Nexus 6P (Android 8.0.0)

Also got this crash. Simple STR:
 1. Enable PWA;
 2. Go to https://pwa.rocks and select any webb app
 3. Add it to homescreen, close FF;
 4. Tap on the PWA created on the screen.

Expected:
 A PWA window opens

Actual:
 App crashes.

Notes:
 Tested on a Huavei Media Pad M2 (Android 5.1.1) & Galaxy S7 (Android 7.0) the issue didn't reproduce on these devices.
Crash signature report: https://crash-stats.mozilla.com/report/index/ac11e6bf-26ca-49b6-ac7b-a14ea0171016
Highly affects launching Progressive web apps.
Constantly crashing while launching the https://paperplanes.world/ & https://www.progressivewebflap.com/ on Android 8.
tracking-fennec: --- → ?
With PWA enabled by default, this crash occurs each time the user clears app data (from the device's Settings) and tries to launch an already installed PWA. Chrome opens the PWA in a new tab if you clear all it's storage data. We should make sure Fennec doesn't crash but somehow handles the already installed web apps, because clearing the app's data is something commonly recommend to users who report an issue we cannot reproduce.
I think this is kind of an edge case, but Dylan was going to fix it anyway. I'll mark it a P1 so we ensure it gets in.
Priority: P3 → P1
Target Milestone: --- → Firefox 58
Best thing we can really hope for here at the moment is to fall back to launching in Fennec.
Attachment #8922103 - Flags: review?(snorp)
tracking-fennec: ? → +
Attachment #8922103 - Flags: review?(snorp) → review+
Pushed by droeh@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/04c3bc16b46e
Fall back to launching Fennec if we've lost the manifest for a PWA. r=snorp
The crash no longer occurs, PWA's that crashed, now are opened in tabs. 
Fixed in Nightly 58 (2017-10-27).

But, only half of the problem seems to be fixed here. If you used to add a PWA and open it right away, there was a crash at launch (comments 3&4). Now, the PWA is at first opened in a new tab and the second time only will be launched as a standalone app. I will open a new bug for this because the users would expect to see something else when they try out the new PWA's.
Status: RESOLVED → VERIFIED
See Also: → 1412301
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.