Process key handle exclusion list when registering a token

RESOLVED FIXED in Firefox 57

Status

()

defect
P2
minor
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ttaubert, Assigned: ttaubert)

Tracking

(Blocks 1 bug)

Other Branch
mozilla58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed, firefox58 fixed)

Details

(Whiteboard: [webauthn])

Attachments

(1 attachment)

It's all there, we just need to forward the exclusion list and make the proper queries in the Rust lib.
Priority: -- → P2
Comment on attachment 8909105 [details]
Bug 1400668 - Process key handle exclusion list when registering a token r=jcj

J.C. Jones [:jcj] has approved the revision.

https://phabricator.services.mozilla.com/D64#1410
Attachment #8909105 - Flags: review+
Pushed by ttaubert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e907fa0c6d37
Process key handle exclusion list when registering a token r=jcj
Pushed by ttaubert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e4294dd8b8c9
Fix Android builds on a CLOSED TREE by adding the key_handles arg to the stub PlatformManager r=bustage
https://hg.mozilla.org/mozilla-central/rev/e907fa0c6d37
https://hg.mozilla.org/mozilla-central/rev/e4294dd8b8c9
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Comment on attachment 8909105 [details]
Bug 1400668 - Process key handle exclusion list when registering a token r=jcj

Approval Request Comment
[Feature/Bug causing the regression]: No regression, missing feature.
[User impact if declined]: Might break testing the U2F/WebAuthn API.
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: Manually, yes.
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: Not risky.
[Why is the change risky/not risky?]: U2F/WebAuthn are not enabled by default.
[String changes made/needed]: None.

This is not critical but it would be nice to have if folks are going to test U2F/WebAuthn in Firefox 57. It's disabled by default but can be enabled via a pref. Low risk because it only touches dom/webauthn.
Attachment #8909105 - Flags: approval-mozilla-beta?
Comment on attachment 8909105 [details]
Bug 1400668 - Process key handle exclusion list when registering a token r=jcj

Happy to help if this remains disabled in 57. 
Should be in 57b3
Attachment #8909105 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1401470
You need to log in before you can comment on or make changes to this bug.