Closed Bug 1404158 Opened 2 years ago Closed 2 years ago

border-radius produces additional lines

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: darkspirit, Assigned: cleu)

References

(Blocks 1 open bug, )

Details

(Keywords: correctness, nightly-community, Whiteboard: [wr-reserve])

Attachments

(5 files)

Attached video 2017-09-29_00-57-21.mp4
Nightly 58 x64 20170928100123 de_DE @ Debian Testing (KDE / Radeon RX480)
gpu-process + layers force accel + webrender (layersfree) + webrendest
This happens in all modes.

Its looking like a "T" that's lying on the side. If I resize the window, the lines may hide and reappear.

This is only if a div contains text. See attached video.

* you might have seen it in 1403976 comment 1, but I didn't mention it there
* twitter's login button looks the same
Attached file wr-testcase.html
missing word.
> * you might have seen it in bug 1403976 comment 1, but I didn't mention it there
Whiteboard: [wr-mvp] [triage]
Also seen on Cloudflare (you have to login and add a domain) on the Caching page: Their custom radio buttons have a horizontal line (diameter) that flicker while scrolling like in comment 0 and comment 1.
Priority: -- → P2
Whiteboard: [wr-mvp] [triage] → [wr-mvp]
mstange: Is this a WebRender bug (something for GitHub) or is this caused by a yet missing feature/Firefox integration?
Probably a WebRender bug, because Gecko doesn't split off the corners from the rest of the border; it forwards along the full border as one shape. And rounded borders are a fully supported feature now.
It might also be a driver bug because I can't reproduce the issue on my Mac.

Could you file an issue on GitHub?
Duplicate of this bug: 1406702
Nightly 58 x64 20171013100112 de_DE @ Windows 10 1703 (Radeon RX480)
fresh profile: webrender + webrendest + blob-images (&disabled pocket/GMP/EME)

I can see those lines even on divs without text.
OS: Linux → All
Summary: border-radius produces additional lines if div contains text → border-radius produces additional lines
Duplicate of this bug: 1409237
I can reproduce it on my Macbook pro with nvidia GT750M

See the strange cross inside the spinner below.

But weird enough, I didn't see lines when I open the test page in the attachment.
(In reply to Michael Leu[:Lenzak](UTC+8) from comment #10)
> But weird enough, I didn't see lines when I open the test page in the attachment.

Try to zoom in and/or resize the window. (Maybe this is a bit like bug 1401665 comment 7.)
Priority: P2 → P3
Whiteboard: [wr-mvp] → [wr-reserve]
OH, I see the strange lines in the test page.

It seems that the bogus line only present in some zoom ratio.
Assignee: nobody → cleu
Status: NEW → ASSIGNED
Priority: P3 → P1
Keywords: correctness
Duplicate of this bug: 1414111
Verified fixed in Nightly 58 x64 20171104100412 de_DE @ Debian Testing (KDE, Radeon RX480). Thank you!!

Testcase: https://bugzilla.mozilla.org/attachment.cgi?id=8913468
YouTube: Loading circle on https://www.youtube.com/watch?v=W_ve0qDCr2k
Twitter: login/register buttons
Cloudflare: Radio buttons on caching page

layers.acceleration.force-enabled, gfx.webrender.enabled
mozregression --bad 2017-11-03 --good 2017-11-04 --profile-persistence clone-first --find-fix
(a few builds were broken)
> 12:51.10 INFO: First good revision: f7af48305978405e52c1b61920b3a51746249579
> 12:51.10 INFO: Last bad revision: 4dc4eae45e0a8c6562692a8509b512a8b6a088cb
> 12:51.10 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4dc4eae45e0a8c6562692a8509b512a8b6a088cb&tochange=f7af48305978405e52c1b61920b3a51746249579

Fixed by https://github.com/servo/webrender/pull/1975 which is included in bug 1413178 comment 10.
GitHub issue: https://github.com/servo/webrender/issues/1805

(Could you mark this as fixed?)
Has STR: --- → yes
Depends on: 1413178
Hardware: x86_64 → All
Fixed by the webrender update in bug 1413178.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Status: RESOLVED → VERIFIED
Blocks: 1403297
You need to log in before you can comment on or make changes to this bug.