Closed Bug 1406841 Opened 2 years ago Closed 2 years ago

Migrate browser_webconsole_property_provider.js to the new frontend

Categories

(DevTools :: Console, enhancement, P1)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 59

People

(Reporter: nchevobbe, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(2 files)

No description provided.
Priority: P3 → P2
Whiteboard: [newconsole-mvp]
Comment on attachment 8941230 [details]
Bug 1406841 - remove js property provider mochitests;

We could migrate the test to e10s (and remove the version in the old frontend, since it doesn't assert anything frontend-related). That's what I do in this patch

However I feel like the feature is already covered through:
- https://searchfox.org/mozilla-central/source/devtools/shared/webconsole/test/unit/test_js_property_provider.js
- https://searchfox.org/mozilla-central/source/devtools/shared/webconsole/test/test_jsterm_autocomplete.html

So maybe we should simply delete the browser mochitests here in favor of the xpcshell test + chrome mochitest?
Attachment #8941230 - Flags: feedback?(bgrinstead)
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P2 → P1
See Also: → 1404849
(In reply to Julian Descottes [:jdescottes][:julian] from comment #2)
> We could migrate the test to e10s (and remove the version in the old
> frontend, since it doesn't assert anything frontend-related). That's what I
> do in this patch
> 
> However I feel like the feature is already covered through:
> -
> https://searchfox.org/mozilla-central/source/devtools/shared/webconsole/test/
> unit/test_js_property_provider.js
> -
> https://searchfox.org/mozilla-central/source/devtools/shared/webconsole/test/
> test_jsterm_autocomplete.html
> 
> So maybe we should simply delete the browser mochitests here in favor of the
> xpcshell test + chrome mochitest?

Yeah, we don't need this as a mochitest. Nothing relevant to the test requires the browser chrome. Good find - I'd go ahead and remove both versions.
Comment on attachment 8941230 [details]
Bug 1406841 - remove js property provider mochitests;

Thanks Brian! I'll send a new patch removing the existing tests.
Attachment #8941230 - Flags: feedback?(bgrinstead)
Comment on attachment 8941230 [details]
Bug 1406841 - remove js property provider mochitests;

https://reviewboard.mozilla.org/r/211496/#review218324

Thanks!
Attachment #8941230 - Flags: review?(bgrinstead) → review+
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/715ae6e13c97
remove js property provider mochitests;r=bgrins
https://hg.mozilla.org/mozilla-central/rev/715ae6e13c97
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Product: Firefox → DevTools
Duplicate of this bug: 1243969
You need to log in before you can comment on or make changes to this bug.