Raspy distorted voice with static noise and a one second delay in WebRTC call (regression)

RESOLVED DUPLICATE of bug 1406027

Status

()

defect
P1
critical
Rank:
5
RESOLVED DUPLICATE of bug 1406027
2 years ago
2 years ago

People

(Reporter: jib, Assigned: achronop)

Tracking

({regression})

55 Branch
Unspecified
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(thunderbird_esr52 unaffected, firefox-esr52 unaffected, firefox56- wontfix, firefox57- fixed, firefox58 fixed)

Details

STRs:
 1. Use a headset
 1. Open https://jsfiddle.net/jib1/cknfm2tL/ in two different tabs.
 2. In first tab, click the [Call] button and share cam + mic.

Expected result:
 - When speaking, you hear yourself fine in headset.

Actual result:
 - Raspy distorted voice with static noise and a one second delay.

Regression range:

13:07.61 INFO: Narrowed inbound regression window from [69e98254, 73260f7c] (4 revisions) to [00f29274, 73260f7c] (2 revisions) (~1 steps left)
13:07.61 INFO: No more inbound revisions, bisection finished.
13:07.61 INFO: Last good revision: 00f292748b3e702f338589863b986f2ee50d55cf
13:07.61 INFO: First bad revision: 73260f7c6dae11039cc4c738ac8714671d8cd1df
13:07.61 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=00f292748b3e702f338589863b986f2ee50d55cf&tochange=73260f7c6dae11039cc4c738ac8714671d8cd1df

Regressed in bug 971528, Firefox 55.

I found this trying to reproduce bug 1405893. There's a chance they're the same, though the symptoms here are instant.
Note that a headset is not required to reproduce, it just makes the problem stand out more.
According to Alex the patch for bug 1406027 seems to help.

If that's the case I would have expected this to be regression from a combination of bug 1319445 and bug 1243857 (for mac), or more recently, bug 1330360. In any case, not bug 971528.

Similar to bug 1381638 but I think bug 1406027 fixes the root cause of those distortions.
Assignee

Comment 3

2 years ago
Regression bug is wrong I'll find a new regression range. Patch from bug 1406027 solves the problem.
Depends on: 1406027
Assignee

Comment 4

2 years ago
mozregression result:
15:19.09 INFO: Narrowed inbound regression window from [15cc8dd6, 967aac2f] (3 builds) to [15cc8dd6, 29ac12c8] (2 builds) (~1 steps left)
15:19.09 INFO: No more inbound revisions, bisection finished.
15:19.09 INFO: Last good revision: 15cc8dd663627ec12ecd4be11a69f0caad8e4e11
15:19.09 INFO: First bad revision: 29ac12c81bcda10a981dfe3371f70a9b17a19edd
15:19.09 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=15cc8dd663627ec12ecd4be11a69f0caad8e4e11&tochange=29ac12c81bcda10a981dfe3371f70a9b17a19edd

paul@paul.cx
Thu Jun 29 20:39:37 2017 +0000	29ac12c81bcd	Paul Adenot — Bug 1341555 - Make static analysis happier.
	5c2fea87df16	Paul Adenot — Bug 1341555 - Consolidate use of the MSG's AbstractMainThread, and stop having AbstractMainThread on MediaStreams. r=pehrsons
	e0c4f2ca44b4	Paul Adenot — Bug 1341555 - Label MSG runnables. r=pehrsons
	5de53323f3ad	Paul Adenot — Bug 1330360 - Create new MSGs for each nsPIDOMWindow. r=jesup
	1c4d113ff7fb	Paul Adenot — Bug 1371719 - Don't create a MediaStreamGraph without doing anything with it. r=jesup
	3da6bb01f447	Paul Adenot — Bug 1372247 - Make the AudioOutputObserver a member of the MediaEngineWebRTCMicrophoneSource so it's not a global singleton anymore. r=jesup
Assignee

Updated

2 years ago
Blocks: 1330360
No longer blocks: 971528
I just redid the regression range and I still get the range in comment 0!
Note I have a new 2016 MBP with stereo mic. Might that explain why I'm seeing a different regression range from Alex and Andreas?
too late for 56, and probably not worth tracking for 57.
Assignee

Comment 8

2 years ago
[Tracking Requested - why for this release]:
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1406027
jib, since you had a different regression range, could you verify that this works in latest nightly?
Flags: needinfo?(jib)
wfm.
Flags: needinfo?(jib)
You need to log in before you can comment on or make changes to this bug.