RFE:[PATCH] Make search phrases more localizable

RESOLVED INVALID

Status

SeaMonkey
Bookmarks & History
RESOLVED INVALID
16 years ago
5 years ago

People

(Reporter: Tsahi Asher, Unassigned)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

Attachments

(7 attachments, 2 obsolete attachments)

(Reporter)

Description

16 years ago
in the Search Bookmarks window (Bookmarks Manager: Tools|Search Bookmarks), when
localizing to Hebrew, i need extra text between the two drop down menues. a
moment of Hebrew: in hebrew, if i wanted to look for a bookmark who's Name
Contains "foo", i would write something like:

Find bookmarks that the [name] of them [contains] "foo"

they way things are now, i don't have a place to put the 'of them' part, and so
i'm forced to add it to each item in the second dropdown.

to fix this, you only need an extra entity at
http://lxr.mozilla.org/seamonkey/source/xpfe/components/bookmarks/resources/locale/en-US/findBookmark.dtd
to contain this entity, or remain empty in languages that don't require it.
(Reporter)

Comment 1

16 years ago
Created attachment 81385 [details] [diff] [review]
fixed findBookmark.xul

i know nothing in XUL/XML, so this was pure guesswork. but it works ok. feel
free to make a better patch.
(Reporter)

Comment 2

16 years ago
Created attachment 81386 [details] [diff] [review]
corresponding fixed findBookmark.dtd
(Reporter)

Updated

16 years ago
Summary: RFE: add text between the dropdowns at Seach Bookmarks window → RFE: add text between the dropdowns at Search Bookmarks window

Comment 3

16 years ago
I think smontagu is a better owner than me.
Assignee: yokoyama → smontagu

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → kasumi

Comment 4

16 years ago
tsahi_75@yahoo.com (Tsahi Asher):
1. you need to attach you suggest fix in "cvs diff -u" format
Please attach screenshot with the following
1. before patch english version
2. after patch english version
3. after patch hebrew version.
Thanks

reassign to default "Bookmark" owner. 
Assignee: smontagu → ben
Component: Internationalization → Bookmarks
QA Contact: kasumi → claudius
(Reporter)

Comment 5

16 years ago
>1. you need to attach you suggest fix in "cvs diff -u" format

i don't have a clue about how cvs works. all i can offer is the files i already
attached. as for screenshots, i'll put them up tomorrow.
Created attachment 81935 [details] [diff] [review]
cvs diff -u from Tsahi's files
Attachment #81385 - Attachment is obsolete: true
Attachment #81386 - Attachment is obsolete: true
Tsahi, try using PatchMaker for creating diffs:
http://www.gerv.net/software/patch-maker/build-mode.html

Comment 8

16 years ago
We should add a localization comment, so the translator/localizer will understand
what this is for.  rchen or yxia can advise.
(Reporter)

Comment 9

16 years ago
Created attachment 82067 [details]
find bookmarks, ofit = ""

that's how the Find Bookmarks dialog looks like with the modification, in
english, with the extra entity empty.
(Reporter)

Comment 10

16 years ago
Created attachment 82069 [details]
find bookmarks, ofit="of it"

that's how the Find Bookmarks dialog looks like in english, with the extra
entity having the value "of it".
(Reporter)

Comment 11

16 years ago
Created attachment 82070 [details]
Hebrew dialog, ofit="שלהן"

that's how the Find Bookmarks dialog looks like, after being translated to
hebrew, with the extra entity put in use.

you might see how the down arrow behaves in drop down menues when the UI is
aligned to the right, but that's for another bug...
(Reporter)

Comment 12

16 years ago
Created attachment 82075 [details]
original dialog

and that's how it looks without the modification.

Comment 13

16 years ago
The "of it" makes somewhat confusing for Asian language localization, see 
attached screenshot below which is current situation, if add "of it" in, we 
must leave that entity as blank for CCJK.

Comment 14

16 years ago
Created attachment 82097 [details]
Current JA screeshot, can not have "of it"

Comment 15

16 years ago
My suggestion, if you do want to add "of it", we may need:
1) Make sure it still works if leave the entity value as blank;
2) Write some localization notes, tell localizer what it is for.
(Reporter)

Comment 16

16 years ago
>1) Make sure it still works if leave the entity value as blank;

see attachment 82067 [details]

>2) Write some localization notes, tell localizer what it is for.

how about "use this entity if needed by your language. leave empty otherwise."

also, of course this entity will be left empty in some languages, maybe even
most of them. even in English. the only thing is, that in this case, the (empty)
gap between the two drop-downs is sligtly larger than in the original form.
compare attachment 82067 [details] and attachment 82075 [details].

Comment 17

16 years ago
That's fine then. Thanks.

Comment 18

16 years ago
I'd like to see if we can find a more generic solution.

This proposal may solve the localization for a few languages in a few dialogs,
but I think we need a more generic solution.

We have several entries for each dropdown:
    [Noun Phrase Dropdown] <phrase (e.g., "of it")> [Verb Phrase Dropdown]

Will there be a single common <phrase> in each language that works for
each combination?

In the Bookmark Search case, the list of verb phrases are the same for each
noun phrase.  In the Mail Search case, there are different lists of verb
phrases for the various noun phrases.  This makes it less likely that a
single <phrase> will work for all combinations.

The bigger problem with a dialog which builds sentences/phrases
from several dropdowns and text boxes is the ordering of sub-phrases.  The
ordering of the noun and verb phrases in some languages are different than
for English.  Adding an optional <phrase> does not solve this problem.

In these cases, we could
 (a) make the ordering/layout of the widgits localizable, or
 (b) use a UI which does not try to create sentences/phrases, or
 (c) ...

Possibly, we could use localizable style sheets for (a)?

I'm glad this bug has been filed, but I'd like to find a more generic
solution and not patch this for individual languages and dialogs.
Unfortunately, the localizations to-date have been doing awkward things
to work with the current design.

Comment 19

16 years ago
Created attachment 82305 [details]
Current Japanese dialogs

Agree with Bob. We can not just make this change for that specific dialog, we
need to consider a general solution for all. See attached Japanese dialogs
above, it's not that simple, not just "of it" thing.

Please change the bug summary and make it for general layout issue.
(Reporter)

Comment 20

16 years ago
Is this summary ok?

btw, about the same time i opened this bug i also opened a similar bug about the
"Find in History" dialog, which is very similar. see bug 140757.
Component: Bookmarks → Layout
OS: Windows 98 → All
Summary: RFE: add text between the dropdowns at Search Bookmarks window → RFE: Make search phrases more localizable

Comment 21

16 years ago
Ying, Thanks for the screen shots of the Japanese localized dialogs.
I didn't realize they looked that bad. :-(

cc'd lorikaplan@netscape.com because this is a general UI issue which needs
to be addressed.  This may be too late to change for 1.0, but it will take
some thoughtful design work to remedy the problems.

Comment 22

16 years ago
Marking NEW for patch loving.
Assignee: ben → sgehani
Status: UNCONFIRMED → NEW
Component: Layout → Search
Ever confirmed: true
Summary: RFE: Make search phrases more localizable → RFE:[PATCH] Make search phrases more localizable

Comment 23

16 years ago
-> Bookmarks
Assignee: sgehani → ben
Component: Search → Bookmarks
Assignee: bugs → p_ch
QA Contact: claudius → seamonkey.bookmarks
Product: Browser → Seamonkey

Comment 24

12 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody

Comment 25

5 years ago
Current bookmarks search dialog contain only one search line, so I suppose this should be closed then?
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA]

Comment 26

5 years ago
That UI is gone. This bug is INVALID.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA] → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.