Closed Bug 1408398 Opened 2 years ago Closed 2 years ago

Location bar sometimes not responding to enter

Categories

(Firefox :: Address Bar, defect, P3)

52 Branch
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: linus.kardell+mozillabugs, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170921064520

Steps to reproduce:

1. Made a fresh installation on OpenSUSE Leap 42.3
2. Typed in URL bar
3. Pressed enter

Not sure what triggers it. Sometimes it seems to happen after closing a tab. Sometimes pressing backspace when it's happening causes the drop-down menu to appear and the location bar to start responding to enter again.


Actual results:

Nothing. The drop-down menu also does not appear.


Expected results:

Firefox goes to the URL, or searches for it if it's not a URL.
Component: Untriaged → Address Bar
I assume you don't have any add-ons that may affect the Address Bar?
Flags: needinfo?(linus.kardell+mozillabugs)
I've also experienced this a couple of times before, but not often enough to bother filing a bug. But today had spare time to look up this bug.

It occurs usually when I copy and paste to the address bar really fast and press enter. Pressing enter has no effect. Then I press enter a few more times and still no reaction. I navigate left and right with the arrow keys to simulate some interaction and press enter again and still no reaction. Then I need to backspace the last character and add it again and press enter for the enter to be recognized.

Hope this helps.
FYI, I tried to find out what caused the bug in "urlBindings.xml" but the address bar code is too convoluted!
I bet this is the deferred key event handling we added not too long ago.  I wouldn't be surprised if there are bugs.  Setting a relatively high priority for investigation, but I haven't confirmed it, so I'll leave it unconfirmed.
Priority: -- → P3
I do not have anything that should affect the location bar. It happened on a fresh install if I remember correctly. What I do have is slow disk I/O, as the /home partition is on an NFS mount over 100 mb/s Ethernet.
Flags: needinfo?(linus.kardell+mozillabugs)
See Also: → 1418251
Ah, nfs is bogus and not very well supported in Firefox.
The problem is that nfs lies about locking to Sqlite, that is the database library we use. Due to that sometimes Sqlite gets confused, and our code may hang or misbehave waiting for that. It's not fixable because the fs is bogus by itself and unlikely to be changed.
We have a setting that *could* help, storage.nfs_filesystem (bool) can be created in about:config and set to true, but if it's also slow over a 100mbps network, hard to tell what happens.

I'm not sure I have a very good solution to suggest for this case, apart from moving to a local profile. Our delayed Enter code should already be timing ot after 200ms :(
See Also: → 1427166
Depends on: 1438329
I'm fairly confident that bug 1438329 fixed this, so I'm going to mark it fixed.  I could be wrong, but in the absence of other evidence I think it's likely.  Please keep an eye on this and if it still happens in Firefox 60, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1547826
You need to log in before you can comment on or make changes to this bug.