Closed Bug 1410557 Opened 2 years ago Closed 2 years ago

Very slow scrolling on cpu.userbenchmark.com comparison page

Categories

(Core :: Graphics: WebRender, defect, P1)

58 Branch
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: yoasif, Assigned: kats)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(1 file)

Steps to reproduce:

turn on gfx.webrender.enabled
turn on gfx.webrendest.enabled
turn on gfx.webrender.layers-free
turn on gfx.webrender.blob-images
turn on layers.acceleration.force-enabled

1. Navigate to http://cpu.userbenchmark.com/Compare/Intel-Pentium-G4600-vs-Intel-Core-i5-2500K/3894vs619
2. Scroll down page


Actual results:

Very slow scrolling. 


Expected results:

Scrolling down page should be as fast or faster than with WebRender off.
Nightly 58 x64 20171020100426 de_DE @ Debian Testing (KDE, Radeon RX480).
main profile:  layers force accel + webrender + webrendest + blob-image + gpu process + omtp + uBlock & basic TP
fresh profile: layers force accel + webrender + webrendest + blob-image

I can't reproduce in both profiles. Pos1/End, scrolling by mousewheel (and autoscrolling in my main profile) are fast as without WebRender.
Perhaps it is driver or hardware related? My GPU is not as good as yours. Attached about:support details.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1410556
:darkspirit not sure how this is a duplicate -- do you know that these are the same root cause?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Apologies. I learned to mark such (comment 2) extreme similar looking bugs as duplicate to concentrate them and to re-check when the target bug got fixed to either verify or reopen them. At least we have connected them in some way now.
Whiteboard: [wr-mvp] [triage]
Status: REOPENED → NEW
Priority: P3 → P2
Whiteboard: [wr-mvp] [triage] → [wr-mvp]
See Also: → 1408174
Whiteboard: [wr-mvp] → [wr-mvp][gfx-noted]
Priority: P2 → P3
Whiteboard: [wr-mvp][gfx-noted] → [wr-reserve] [gfx-noted]
Wouldn't say page performance is *great* on my machine, but not to the level as to when I initially reported it.

11:20.32 INFO: Narrowed inbound regression window from [fba516dc, 1613834d] (3 builds) to [fba516dc, 2fc7e206] (2 builds) (~1 steps left)
11:20.32 INFO: No more inbound revisions, bisection finished.
11:20.32 INFO: First good revision: 2fc7e2060d1f66cd9600f6c890578b3a1641738d
11:20.32 INFO: Last bad revision: fba516dc5620ea600c8cfb09ab018458a57c7bb2
11:20.32 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=fba516dc5620ea600c8cfb09ab018458a57c7bb2&tochange=2fc7e2060d1f66cd9600f6c890578b3a1641738d
Status: NEW → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Priority: P3 → --
Resolution: FIXED → WORKSFORME
Whiteboard: [wr-reserve] [gfx-noted] → [gfx-noted]
Assignee: nobody → bugmail
Resolution: WORKSFORME → FIXED
Priority: -- → P1
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
You need to log in before you can comment on or make changes to this bug.