Closed Bug 1411230 Opened 2 years ago Closed 2 years ago

Synced tabs search box icon should move to the left

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 59
Tracking Status
firefox59 --- verified

People

(Reporter: valentina.ona, Assigned: daleharvey)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

Attached image sidebar.png
Mozilla/5.0 (Windows NT 6.1; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID 20171023220222

Affected version: Firefox Beta 57.0b10 and Nightly 58.0a1

Affected platforms: Windows 7 x32, Windows 10 x64, Ubuntu 16.04

[Steps to reproduce]: 
1. Launch Nightly 58.0a1
2. Enable the sidebar

[Expected result]: The search icon, text from the search field and search box match with the spec.

[Actual result]:  -The search icon is on the right side(on Ubuntu and Windows)
-The text from the search field is "Search synced tabs" (on Ubuntu and Windows)
-The search box has square corners(on Windows)

[Note:] Please see the attachment!! 

This is a follow up of 1355330
Whiteboard: [reserve-photon-visual]
Depends on: 1355330
Whiteboard: [reserve-photon-visual] → [reserve-photon-visual][triage]
(In reply to Valentina Claudia Ona from comment #0)
> [Actual result]:  -The search icon is on the right side(on Ubuntu and
> Windows)

Yeah, that's buggy because the synced tabs sidebar is implemented in HTML and a big mess. :(

> -The text from the search field is "Search synced tabs" (on Ubuntu and
> Windows)

Not sure if this was actually supposed to change or just an arbitrary difference in the mockup.

> -The search box has square corners(on Windows)

As far as I remember, Stephen said the native textbox styling is fine here.

Reducing the scope of this bug to the first issue so that it's actionable.
Component: Bookmarks & History → Theme
OS: Windows → All
Priority: -- → P4
Summary: Restyle sidebar to match Photon spec (Bookmarks, Sync, History on Windows and Ubuntu) → Synced tabs search box icon should move to the left
Whiteboard: [reserve-photon-visual][triage] → [reserve-photon-visual]
Assignee: nobody → dharvey
Status: NEW → ASSIGNED
Priority: P4 → P1
Comment on attachment 8928187 [details]
Bug 1411230 - Move synctab sidebar search icon to left.

https://reviewboard.mozilla.org/r/199412/#review204536

::: browser/themes/linux/syncedtabs/sidebar.css:42
(Diff revision 1)
> -  width: 16px;
> -  height: 16px;
>    background-image: url(chrome://global/skin/icons/search-textbox.svg);
>    background-repeat: no-repeat;
> -  background-position: center;
> -  display: inline-block;
> +  background-size: 12px 12px;
> +  background-position: left center;

Looks like this doesn't take RTL into account. You can check by setting intl.uidirection to 1 in about:config.
Attachment #8928187 - Flags: review?(dao+bmo) → review-
Filed a new bug for not seeing RTL @ https://bugzilla.mozilla.org/show_bug.cgi?id=1417577
Comment on attachment 8928187 [details]
Bug 1411230 - Move synctab sidebar search icon to left.

https://reviewboard.mozilla.org/r/199412/#review205002
Attachment #8928187 - Flags: review?(dao+bmo) → review+
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9ce9c18806c4
Move synctab sidebar search icon to left. r=dao
https://hg.mozilla.org/mozilla-central/rev/9ce9c18806c4
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Depends on: 1418187
I can reproduce this issue with Nightly 59.0a1 (2017-11-016) on Windows 10 pro, 64 Bit!

This bug's fix is verified with latest Nightly!

Build ID 	20171122220056
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [bugday-20171122]
I verified this issue using Latest Nightly 59.0a1 with Build ID 20171116220410 on Ubuntu 16.04, Windows 7 x64 and Windows 10 x64. I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.