Closed Bug 1411559 Opened 5 years ago Closed 4 years ago

Snap: Let mozilla-release upload on the candidate channel

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set
normal

Tracking

(firefox59 fixed, firefox60 fixed)

RESOLVED FIXED
Tracking Status
firefox59 --- fixed
firefox60 --- fixed

People

(Reporter: u504868, Assigned: u504868)

References

Details

Attachments

(1 file)

I connected to the Snap dashboard, and I realized that ten 58.0b1 releases made the Snap store[1]. 58 hasn't made mozilla-beta yet, then it turns out we're uploading builds from Jamun. 

This is because [2] just check the version number. We should probably pass an argument to the task definition instead. What do you think, Rail? 

[1] https://dashboard.snapcraft.io/dev/snaps/8148/rev/27/
[2] https://dxr.mozilla.org/mozilla-beta/rev/369b0f9bfdf603187e7c94b56a6213f2fe67ceda/taskcluster/docker/firefox-snap/runme.sh#82
Flags: needinfo?(rail)
Bah... We definitely should explicitly pass something to tell the scrip to upload stuff. Something like "runme.sh --publish" maybe?
Flags: needinfo?(rail)
Aki removed the clumsy version number matching in bug 1423081 \o/ I noticed the comments are still outdated there. I cleaned them up. Let's use this bug to let:
* mozilla-beta upload on the edge channel
* mozilla-release upload on the candidate channel

Thus, we should be ready for the 59.0 release.
Assignee: nobody → jlorenzo
Depends on: 1423081
Summary: Jamun should not upload snaps onto the Snap store → Snap: Let mozilla-release upload on the candidate channel
Comment on attachment 8954725 [details]
Bug 1411559 - Snap: Add upload on mozilla-release and restrict channels

https://reviewboard.mozilla.org/r/223858/#review229878

::: taskcluster/docker/firefox-snap/runme.sh:84
(Diff revision 1)
> -if [ "$PUSH_TO_CHANNEL" != "" ]; then
> -  echo "Beta version detected. Uploading to Ubuntu Store (no channel)..."
> +if [[ "$PUSH_TO_CHANNEL" =~ (^(edge|candidate)$)  ]]; then
> +  echo "Uploading to Ubuntu Store on channel $PUSH_TO_CHANNEL"
>    bash "$SCRIPT_DIRECTORY/fetch_macaroons.sh" "http://taskcluster/secrets/v1/secret/project/releng/snapcraft/firefox/$PUSH_TO_CHANNEL"
> -  snapcraft push "$TARGET_FULL_PATH"
> +  snapcraft push --release "$PUSH_TO_CHANNEL" "$TARGET_FULL_PATH"
>  else
> -  echo "Non-beta version detected. Nothing else to do."
> +  echo "No upload done: PUSH_TO_CHANNEL value "$PUSH_TO_CHANNEL" doesn't match a known channel."

Is "$PUSH_TO_CHANNEL" meant to be in quotes in the string that's written out? At the moment this ends the string after 'value', concatenates it, the variable, and the string starting " doesn't" - it works, but it may not be what's intended / looked for in log greppers.
Attachment #8954725 - Flags: review?(sfraser) → review+
Good catch, it is! I escaped the double quotes.
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4a7454c17a0d
Snap: Add upload on mozilla-release and restrict channels r=sfraser
https://hg.mozilla.org/mozilla-central/rev/4a7454c17a0d
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Blocks: 1443432
Duplicate of this bug: 1401616
Duplicate of this bug: 1401615
Macaroons created in comment 4 were revoked and regenrated in bug 1491262 comment 11
Blocks: 1491262
You need to log in before you can comment on or make changes to this bug.