moonshot - 403 from pypi.pvt.build.mozilla.org

RESOLVED FIXED

Status

Infrastructure & Operations
RelOps
RESOLVED FIXED
25 days ago
16 days ago

People

(Reporter: garndt, Assigned: dragrom)

Tracking

Details

(Reporter)

Description

25 days ago
So far this seems to be limited to linux moonshot machines 285-295 and it's not consistent.  403 returned when contacting pypi:

"HTTP error 403 while getting http://pypi.pvt.build.mozilla.org/pub/functools32-3.2.3-2.tar.gz (from http://pypi.pvt.build.mozilla.org/pub/)"



for instance, here is machine 290 failing:
https://tools.taskcluster.net/groups/TAfB_Yr8QLepDAtUUb3dfQ/tasks/J6vjpN8NQU6IBmefWP-8JA/runs/0/logs/public%2Flogs%2Flive_backing.log#L829

but then one that was successful:
https://tools.taskcluster.net/groups/TAfB_Yr8QLepDAtUUb3dfQ/tasks/NE_w283NRKOqyzgJCINbyg/runs/0/logs/public%2Flogs%2Flive_backing.log

Updated

25 days ago
Assignee: relops → dcrisan
(Assignee)

Updated

24 days ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

24 days ago
I cannot reproduce the issue. I tried to manual install jsonschema==2.5.1, but no issue I saw. I also run puppet on the t-linux64-xe-290 host. I'll keep this bug open. If you'll meet other issue related taskcluster-worker on moonshot hardware, please put the logs into the bug
(Assignee)

Comment 2

18 days ago
:garndt I'll close this bug. If you will encounter again the pypi problem, please reopen it.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 days ago
Resolution: --- → FIXED
(Reporter)

Comment 3

18 days ago
Joel, cc'ed you just in case you encounter this issue during your talos testing.

Updated

16 days ago
See Also: → bug 1415655
You need to log in before you can comment on or make changes to this bug.