Closed Bug 1416188 Opened 4 years ago Closed 2 years ago

Badge "number of unread new mails" and progress bar not shown in Ubuntu 17.10 Dock for Thunderbird / Firefox Next (ppa)

Categories

(Thunderbird :: OS Integration, defect)

56 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1482674

People

(Reporter: Valeryan_24, Unassigned)

References

Details

Attachments

(1 file)

Attached image Moz-Next.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171103090157

Steps to reproduce:

I installed Ubuntu 17.10 and the ppa from Mozilla team :

https://launchpad.net/~mozillateam/+archive/ubuntu/thunderbird-next
https://launchpad.net/~mozillateam/+archive/ubuntu/firefox-next


Actual results:

When using the ppa:mozillateam/thunderbird-next and Thunderbird 56.0~b4, on the icon dock it never shows the circle with number of new unread mails, even when new mails arrived.

Same, the progress bar is not visible when downloading a large file on Firefox 57.0~b12 from ppa:mozillateam/firefox-next

Bug reported also for Ubuntu Dock Gnome Shell extension :
https://bugs.launchpad.net/ubuntu/+source/gnome-shell-extension-ubuntu-dock/+bug/1728522


Expected results:

As when using default Ubuntu Artful installation and Thunderbird, we should normally see an orange circle icon with number (in white) of new mails received when Thunderbird is not the active window.

https://didrocks.fr/2017/09/25/ubuntu-gnome-shell-in-artful-day-14/
I don't know why Gnome Shell Ubuntu Dock does not "recognize" application, as their package names (firefox and thunderbird) are the same as those on default Ubuntu installation...

Or extension / needed API are not active in the ppa packages ?

Thanks in advance for your help.
Perhaps a distro build issue. Did your, or they, use 
  ac_add_options "MOZ_ALLOW_LEGACY_EXTENSIONS=1"
or  
  "export MOZ_ALLOW_LEGACY_EXTENSIONS=1" 

If not, they need to.
See Also: → 1416190
I have asked on French Ubuntu forum, where a developer is present.

I forgot to precise (but it is shown on the screenshot) that both Thunderbird (56) badge for unread mails and Firefox (57) progress bar, even for the ppa versions, work well on Unity (Ubuntu 17.04)
(In reply to Xavier from comment #3)
> I have asked on French Ubuntu forum, where a developer is present.

please post the link
Flags: needinfo?(Valeryan_24)
Hi, link of the post (I write there as the Launchpad bug has been marked "invalid" because related to a ppa and not official Ubuntu packages) :

http://forum.ubuntu-fr.org/viewtopic.php?pid=21823419#p21823419
Flags: needinfo?(Valeryan_24)
Since update 57.0b1, I don't see any more "number of unread mails" on Thunderbird icon on Unity dock (17.04), too (Messaging menu and Unity launcher integration is still activated)...

Does "Birdtray" solve (almost) this issue?
https://flathub.org/apps/details/org.gyunaev.Birdtray

Almost as Birdtray

supports Linux and Windows. Patches to support other platforms are welcome.

https://github.com/gyunaev/birdtray/

No, because that just adds a system tray icon. This bug report is about badging Thunderbird's own icon in the dock/panel with the number of unread emails.

(In reply to Nate Graham from comment #8)

No, because that just adds a system tray icon. This bug report is about badging Thunderbird's own icon in the dock/panel with the number of unread emails.

That badge was not provided by Thunderbird, but supplied by an extension from Ubuntu with Thunderbird in Unity.

It is gone with the change from Unity to the Gnome desktop, and with the change in Thunderbird to re-enable Native Linux Notifications starting with Thunderbird 60 is no longer needed. They show the number of new emails.

What do you mean by "is no longer needed"? What shows the number of new emails? I still do not see a badge on the app icon itself showing the number of new emails. That's what's being requested here. Notifications are not a substitute for this feature.

(In reply to Nate Graham from comment #10)

What do you mean by "is no longer needed"? What shows the number of new emails? I still do not see a badge on the app icon itself showing the number of new emails. That's what's being requested here. Notifications are not a substitute for this feature.

Sorry to be the bearer of bad news.

If you are using the Thunderbird provided by the Ubuntu distribution (currently 68.2.2), it is built by Ubuntu from Thunderbird source code with some changes.

One of those changes used to be the inclusion of an extension called Messaging Menu and Unity Launcher Integration. From that extensions information page:

This extension integrates Thunderbird into the Ubuntu Unity messaging menu and launcher.

That is what provided the badge for the Thunderbird icon on the Unity desktop. It never was provided by Thunderbird.

Ubuntu no longer uses the the Unity desktop, has changed to the Gnome desktop and they no longer include that extension with their builds.

That explains why the reporter doesn't see it using the Gnome Shell Ubuntu Dock. It isn't Unity. The mozillateam ppa builds probably didn't include it either.

It explains why we don't see it with Thunderbird 68.2.2 from Ubuntu on Ubuntu 18.04.3 LTS, or the LiveUSB of Ubuntu 18.10 when tested, but do with the LiveUSB of Ubuntu 16.04 when tested.

All we are left with are the native Linux notification which appears at the top of the screen when new mail arrives in Thunderbird on Ubuntu. It is in the lower right corner on my Linux Mint 19.3. I have no idea where it may appear in other distributions. I'm not a fan and always change "mail.biff.use_system_alert" to "false" in Preferences > Advanced > Config Editor to disable it.

I would think this is an invalid bug report since the Thunderbird icon on other Linux distributions and desktops, Windows or Mac doesn't have the count of unread emails in the icon.

No, I'm using Thunderbird from openSUSE Tumbleweed right now.

One of those changes used to be the inclusion of an extension called Messaging Menu and Unity Launcher Integration.

The "Unity Launcher API" is used by more than just Unity (which is indeed now abandoned upstream). KDE Plasma implements it too, and Ubuntu's customized GNOME Dock also implements it (See https://www.omgubuntu.co.uk/2017/09/ubuntu-dock-now-supports-progress-bars-badge-counts). For this reason, other 3rd-party apps such as Telegram already use this API to badge their icons with the number of unread messages. So it's not a dead API that should just be abandoned.

I would think this is an invalid bug report since the Thunderbird icon on other Linux distributions and desktops, Windows or Mac doesn't have the count of unread emails in the icon.

On macOS at least, it surely does. I see it doing this all the time. Don't know about Windows.

But regardless of whether this is a bug or a feature request, the point is that we think Thunderbird should itself implement unread message badging via the Unity Launcher API, which will restore/add this very nice feature for all Thunderbird users who are on Ubuntu or any distro that ships KDE Plasma.

You are correct as was pointed out to me in in bug 1482674 comment 41.

Probably where the Ubuntu developers got the idea for the Unity badge.

Anyway this sounds like a duplicate of that bug asking for a persistent indicator on Linux.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1482674

Yep, looks like a dupe. Thanks!

You need to log in before you can comment on or make changes to this bug.