Create SocketProcessHost and corresponding IPC interfaces

RESOLVED FIXED

Status

()

enhancement
P2
normal
RESOLVED FIXED
a year ago
4 months ago

People

(Reporter: kershaw, Assigned: kershaw)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 affected)

Details

(Whiteboard: [necko-triaged] [SOCK-PROC-M1])

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

a year ago
Add basic skeletal code for socket process:
 - GeckoProcessType
 - empty top-level IPC
 - XPCOM init
 - etc
(Assignee)

Updated

a year ago
Whiteboard: [necko-triaged]
(Assignee)

Comment 1

a year ago
Posted patch WIP (obsolete) — Splinter Review
WIP
This bug will be focusing on creating SocketProcessHost and the corresponding top-level IPDL.
SocketProcess will initialize white-listed XPCOM. JS and cycle collection are not allowed in this process.
Assignee: kechang → cyu
Summary: Skeletal code for socket process → Create SocketProcessHost and corresponding IPC interfaces
Whiteboard: [necko-triaged] → [necko-triaged] [SOCK-PROC-M1]
Assignee: cervantes.yu → valentin.gosu
The socket process may be enabled by setting the envvar NECKO_DEDICATED_PROCESS=1.
At the moment the socket process doesn't do anything. Following its launch, we sync preferences, then start up XPCOM. More features to follow.
Kershaw, as agreed the last week, reassiging to you.
Assignee: valentin.gosu → kershaw
Duplicate of this bug: 1485619
(Assignee)

Comment 6

8 months ago
Summary of changes:
 - Rename
 - Add comments to classes that bring socket process up
 - Fix review comments
   - Remove some unnecessary changes
   - Remove the compiler dependency of nsIOService and IPC headers
   - Launch socket process after user's pref is loaded
(Assignee)

Updated

8 months ago
Attachment #8927741 - Attachment is obsolete: true
Comment on attachment 9003841 [details]
Bug 1416623 - Part1: Socket Process startup machinery r=mayhemer

Kris Maglione [:kmag] has approved the revision.
Attachment #9003841 - Flags: review+
Comment on attachment 9003841 [details]
Bug 1416623 - Part1: Socket Process startup machinery r=mayhemer

Honza Bambas (:mayhemer) has approved the revision.
Attachment #9003841 - Flags: review+
Attachment #8992980 - Attachment is obsolete: true
Fixed on larch:
https://hg.mozilla.org/projects/larch/rev/55a5826ef371574be5dbc56530107e4c82a31742
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED

Updated

7 months ago
Blocks: 1496257
Attachment #9003841 - Attachment is obsolete: true
Attachment #9003841 - Attachment is obsolete: false
(Assignee)

Updated

5 months ago
Duplicate of this bug: 1430045
Attachment #9030453 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.