Closed Bug 141670 Opened 18 years ago Closed 16 years ago

Typing in search terms in the URL bar responds with a "www.keywords typed here.com" not found

Categories

(SeaMonkey :: Location Bar, defect, major)

PowerPC
Mac System 9.x
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 197918

People

(Reporter: hEADcRASH, Assigned: hewitt)

References

()

Details

(Keywords: verifyme)

When typing in keywords (to be searched) in the URL bar and then hitting RETURN,
i received a "www." (my keywords here) ".com not found" dialog box.
Glenn, do you have "internet keywords" enabled under Preferences > Navigator >
Smart Browsing?
No (i didn't know that was an option), however, the tool-tip (or pop-up help (or
whatever you wanna call it)) still said "Search Netscape Search for (my keywords
here)"
Ah, that would be wrong.  :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Have seen similar behaviour on Linux too. If you set 

user_pref("keyword.URL", "http://www.google.com/search?q=");
user_pref("keyword.enabled", true);

and enter "igrep.el Elisp" as the search term, Mozilla returns 
"www.igrep.el elisp" not found. If you enter, "Elisp igrep.el", Mozilla returns
the same error again. Now when I enter, keyword: "igrep.el Elisp", it searches
google correctly. 

I can understand the part when Mozilla sees a foo.bar in the beginning of the
URL, it tries to resolve the name. But shouldn't Mozilla ignore the resolving
part, if there is a space in the middle of the entered URL ? Ignoring space
altogether is not feasible, as someone might enter an extra space at the end of
a perfectly valid URL.

Sometimes depending on the position of the moon etc., Mozilla also confuses
perfectly valid search terms like "foo bar" and tries to resolve 
www.foo bar.com :-(
As I understand it, when you don't have "Internet Keywords" enabled, just
entering some text in the URL bar takes you to the domain with that name. If you
want to search google/whatever, you explicitly have to click on the line "Search
Google/whatever" to search for your keywords.

This seems to be correct behaviour.

glenn: Any chance you confuse the option to search for something (displayed as
"Search Google/whatever for <your keywords>" on grey background in the URL bar
dropdown box) with a hint what mozilla will do?
If you enter any web address in the URL bar, you will still see the "Search ..."
line in the URL bar dropdown.
<Please see Comments #2 and #3>
see bug 141670 comment 4 for temp. fix

*** This bug has been marked as a duplicate of 53171 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → REOPENED
QA Contact: claudius → benc
Resolution: DUPLICATE → ---
See bug to turn on internet keywords.

*** This bug has been marked as a duplicate of 197918 ***
Status: REOPENED → RESOLVED
Closed: 18 years ago16 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.