Long page with many tables scrolls choppily

VERIFIED FIXED

Status

Core Graveyard
GFX
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Susie Wyshak, Assigned: dcone (gone))

Tracking

({perf, topembed+})

Trunk
x86
Windows 2000
perf, topembed+

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 RTM] [ETA 06/18], URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
I'm sure there's a way to evangelize this but hopefully there is something that
can be optimized to smooth scrolling on a page like this.

To replicate: Scroll down http://www.seattlesbest.com/site/locations/

Win2K 2002043006
Susie, is this only choppy on Win2k, or also on Win9x?
(Assignee)

Comment 2

16 years ago
Does this have images, or background tiles.  There was a checkin on the trunk
yesterday that fixed this for images.
Scrolls smoothly using 2002050706 build on WinXP, 750Mhz Athlon, ATI 3D RAGE IIC
AGP graphics card
Reassigning to Don.
Assignee: kmcclusk → dcone
(Assignee)

Comment 5

16 years ago
Created attachment 85264 [details] [diff] [review]
use the progressive doubling if there are more than 32 tiles.

There is a certain optimization to using the progressive doubling. The cost of
creating the offscreen buffers etc can slow down just blitting.. so I tuned
this a little... and it fixes this bug..and does not regress my other test
cases.
(Reporter)

Comment 6

16 years ago
Scrolled smoothly on Win98 with embedded Mozilla 1.0.

(still choppy for me on Win2K with rv:1.0rc2 Gecko/20020512)
(Assignee)

Comment 7

16 years ago
it should still be slow for you because I did not check anything in to the 
branch or the trunk.
(Reporter)

Comment 8

16 years ago
I know...I was just confirming I hadn't had a caffeine induced impatient
scrolling episode.
(Assignee)

Comment 9

16 years ago
Created attachment 85437 [details] [diff] [review]
better patch..
Attachment #85264 - Attachment is obsolete: true
(Assignee)

Comment 10

16 years ago
*** Bug 147799 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: patch, perf
(Assignee)

Comment 11

16 years ago
*** Bug 148036 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: mozilla1.0.1
Comment on attachment 85437 [details] [diff] [review]
better patch..

Please add a comment which explains why the magic value of 32 is being used.
Example:
for tiled backgrounds which require less than 32 blits it is faster to blit
directly to the screen instead of blitting to an offscreen and doing
progressive doubling.


r=kmcclusk@netscape.com.
Attachment #85437 - Flags: review+

Comment 13

16 years ago
cvs diff -u, in the future, please! Does the comment above this line need to
change? Specifically, the part that says: `and the tile is at least 8 times
smaller than the area to update'?
(Assignee)

Comment 14

16 years ago
Created attachment 85649 [details] [diff] [review]
forgot the -u.. and put in a comment.
Attachment #85437 - Attachment is obsolete: true

Updated

16 years ago
Attachment #85649 - Flags: superreview+

Comment 15

16 years ago
Comment on attachment 85649 [details] [diff] [review]
forgot the -u.. and put in a comment.

sr=waterson
(Assignee)

Comment 16

16 years ago
*** Bug 149224 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
Comment on attachment 85649 [details] [diff] [review]
forgot the -u.. and put in a comment.

please land this on the 1.0.1 branch. once there remove the "mozilla1.0.1+"
keyword, and add the "fixed1.0.1"

we're willing to go w/ no trunk baking first on this  minor (apparently :-) )
tuning.
Attachment #85649 - Flags: approval+

Updated

16 years ago
Keywords: mozilla1.0.1 → mozilla1.0.1+

Updated

16 years ago
Blocks: 46942

Comment 18

16 years ago
Has this been checked into trunk? I see a vast scrolling perf difference from
1.0 release, when using 2002060908, Win2K on the above site. No exactly IE
parity but very close to it.
(Assignee)

Comment 19

16 years ago
fixed. Checked into the trunk.
(Assignee)

Comment 20

16 years ago
fixed.. forgot to mark
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: mozilla1.0.1+ → fixed1.0.1
Resolution: --- → FIXED
(Assignee)

Updated

16 years ago
Keywords: fixed1.0.1 → mozilla1.0.1+

Comment 21

16 years ago
adt1.0.1+ (on ADT's behalf) for checkin to the 1.0 branch. pls check this in
asap, then add the "fixed1.0.1" keyword.
Keywords: adt1.0.1+, nsbeta1+
Whiteboard: [adt2 RTM] [ETA 06/18]
(Reporter)

Comment 22

16 years ago
It scrolls like a dream! (6/20 trunk) Thanks!
Keywords: topembed+
(Assignee)

Comment 23

16 years ago
well..I can not check this into the branch.. seems the branch is missing many
pieces to this puzzle (lots of patches has changed this code) and its not up to
date enough to take this simple patch.

Comment 24

16 years ago
Removing adt1.0.1+, as a result of Comment #23 From dcone@netscape.com.
Keywords: adt1.0.1+
Removing mozilla1.0.1+; see new bug assigned to dcone for pulling this and the
related earlier tiling patches into the branch for 1.0.2
Keywords: mozilla1.0.1+
(Reporter)

Comment 26

15 years ago
This bug should be reopened correct? It is critical to get this issue fixed and
on the branch for embedding please. 

Comment 27

15 years ago
susiew: I believe that the bug that rjesup was referring ot is bug 162747: 
"Update branch tiling drawing/doubling code to match trunk". Per comment 23,
dcone notes that he can't directly apply the trunk changes on the branch.

Comment 28

15 years ago
Ok. Using 2002081308 trunk on this site http://www.mr4000.com/, scrolling is out
of control. I can't even use the page at all.
(Reporter)

Comment 29

15 years ago
Comment #28 problem also occurs in Gecko/20020821 commercial branch build, I
guess as expected.

These sites are still scroll poorly in this build but I'll copy these comments
to the bug 162747

http://www.seattlesbest.com/site/locations/
http://www.sfgate.com/traffic/ (which I thought was due to bug 153217)

FYI the other site in bug 153217 scrolls fine.
this looks fine using a recent (2003.06.10.05-1.4) build on win2k. marking verified.
Status: RESOLVED → VERIFIED

Comment 31

14 years ago
Looking at http://jobs.volt.com/JobSearch/Jobs.cfm with 2003090204 trunk seems
to indicate that this bug is not fixed. It is so bad on that page that even
moving the mouse around the page consumes major CPU power. Removing the
background GIF from the pages fixes the behavior.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.