Closed Bug 1418081 Opened 2 years ago Closed 2 years ago

Update builders to rust 1.23.0

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: rillian, Assigned: rillian)

References

Details

Attachments

(1 file)

Rust 1.23.0 is scheduled for stable release 2018 January 4. Update builders when that release is available.
Depends on: 1418083
Depends on: 1420301
Depends on: 1424256
Attachment #8940784 - Flags: review?(core-build-config-reviews)
Attachment #8940784 - Flags: review?(core-build-config-reviews)
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa0e2d59775c
Update builders to rust 1.23.0. r=ted
These look like bug 1418083.
Flags: needinfo?(giles)
Depends on: 1430315
Depends on: 1430320
Given there are still outstanding bugs blocking this from landing, and that we're now one week away from uplift to Firefox 59 beta, I plan to leave Firefox 59 building with Rust 1.22.0. We'll update as soon as possible once m-c becomes Firefox 60 Nightly.
Did you check talos? The landing of bug 1401647, which effectively made 32-bits builds use 1.22 instead of 1.23 beta showed performance improvements, suggesting performance regressions from rust 1.23 codegen.
I haven't done a talos run, no.
Blocks: 1430934
Try push, with talos this time. https://treeherder.mozilla.org/#/jobs?repo=try&revision=cc02c849cb0a453319663ccac8b0fd298f2a8f40

Looks like another valgrind issue has snuck in.
Valgrind issue isn't showing up this week, so trying again.
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/28ee1007dae0
Update builders to rust 1.23.0. r=ted
https://hg.mozilla.org/mozilla-central/rev/28ee1007dae0
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
This improved some Stylo tests:

== Change summary for alert #11278 (as of Wed, 24 Jan 2018 23:42:28 GMT) ==

Improvements:

 11%  Stylo Servo_DeclarationBlock_SetPropertyById_Bench osx-10-10 opt      602,051.67 -> 537,327.00
 11%  Stylo Servo_DeclarationBlock_SetPropertyById_WithInitialSpace_Bench osx-10-10 opt 604,456.83 -> 539,541.75

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=11278
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.