Always override the colors specified by the page should change the tabbrowser background color

VERIFIED FIXED in Firefox 59

Status

()

defect
P2
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: erfiaschi, Assigned: florian)

Tracking

({access, regression})

57 Branch
Firefox 60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 wontfix, firefox59 verified, firefox60 verified)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

1. Start Firefox by clicking on the desktop icon
2. Go to Options -> Language and Appearance
3. Click Colors
4. Set black for background, green for text. Override Always
5. Open new tab


Actual results:

Screen is white until page loads. White flash when closing tab.


Expected results:

Screen should have stayed black like in previous versions.
Thank you very much.
I know you have bigger problems but I use high contrast on windows since I have permanent vision impairments. Would make a huge difference for everyone with my conditions.
I appreciate your efforts. Firefox is always the best!
Component: Untriaged → Graphics
Keywords: access
Product: Firefox → Core
Excuse me, why is it unconfirmed?
It happens for real. You just have to try for yourselves to see that it is true.
Thank you very much.
With kindness,
Andrea
Sorry! Hadn't got to it yet in my triage backlog. I can indeed confirm it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Milan, we should prioritize this fairly highly since it's a fairly nasty accessibility regression. Handing off to you to assign as you see fit. Might not be strictly speaking a graphics issue (we shouldn't be trying to draw tabs that don't have their content properly hooked up).
Flags: needinfo?(milan)
:dbolter, need some guidance here as to what we should expect to happen
Flags: needinfo?(milan) → needinfo?(dbolter)
This feels like a Ux question. I'll try to triage it into a closer component...
Component: Graphics → Theme
Flags: needinfo?(dbolter)
Product: Core → Firefox
(In reply to Alexis Beingessner [:Gankro] from comment #4)
> Milan, we should prioritize this fairly highly since it's a fairly nasty
> accessibility regression.

Is it in fact a regression? Do you have range?

Could be caused by bug 1379587, I suppose.
Flags: needinfo?(a.beingessner)
See Also: → 1422507
I'm taking the user's word on it being a regression. I tagged the issue as regressionwindow-wanted because I don't have any details.
Flags: needinfo?(a.beingessner)
(In reply to Alexis Beingessner [:Gankro] from comment #8)
> I'm taking the user's word on it being a regression. I tagged the issue as
> regressionwindow-wanted because I don't have any details.

Your comment 4 appears to be the first to make that claim...
Florian, could you take a look here as well? I suspect this is a regression from bug 1379587.
Blocks: 1379587
Flags: needinfo?(florian)
Seems to be the same as bug 1419152, ie. we shouldn't set the tabbrowser background to the in-content page background when the background color has been customized and "Override the colors specified by the page with your selections above" is enabled.
I think you're right, Florian.
That is the issue.
Many thanks to all of you guys working hard to improve the already best browser in the world!
You are very intelligent, smart and brave.
Cheers!
Thank you!
Priority: -- → P2
See Also: → 1419152
Posted patch PatchSplinter Review
Attachment #8945532 - Flags: review?(gijskruitbosch+bugs)
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #8945532 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3c6c006a315f
the user specified background color should be used for the tabbrowser background when 'Always override the colors specified by the page' is selected, r=Gijs.
https://hg.mozilla.org/mozilla-central/rev/3c6c006a315f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Flags: needinfo?(florian)
Summary: Colors Disappear while loading pages → Always override the colors specified by the page should change the tabbrowser background color
Comment on attachment 8945532 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/Bug causing the regression]: bug 1379587
[User impact if declined]: uses of the 'Always override the colors specified by the page' setting will see light gray flashes when opening tabs or windows. This is likely to include Linux users with dark themes.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: doesn't look like it
[Needs manual test from QE? If yes, steps to reproduce]: would be nice to test at the same time as bug 1419152.
[List of other uplifts needed for the feature/fix]: would make sense to uplift at the same time as bug 1419152
[Is the change risky?]: no
[Why is the change risky/not risky?]: This reverts to the behavior we had before bug 1379587 for the 'Always override the colors specified by the page' edge case.
[String changes made/needed]: none
Attachment #8945532 - Flags: approval-mozilla-beta?
Flags: qe-verify+
It looks like bug 1422507 may be related, so if someone from QE is verifying this issue, you might also check the STR in bug 1422507.
Flags: needinfo?(andrei.vaida)
I still can reproduce this issue on Windows 10 x64 and Windows 7 x86 following the steps in description on the latest Firefox Nightly 60.0a1 (2018-02-02). White flash is displayed after opening a new tab after that the page turns into black.
Flags: needinfo?(andrei.vaida) → needinfo?(florian)
Florian, any luck with this?
(In reply to Hani Yacoub from comment #18)
> I still can reproduce this issue on Windows 10 x64 and Windows 7 x86
> following the steps in description on the latest Firefox Nightly 60.0a1
> (2018-02-02). White flash is displayed after opening a new tab after that
> the page turns into black.

Indeed I can still reproduce on Windows. I think I focused on Linux (or Mac?) when I worked on this bug, because this matters more for these platforms that don't have high contrast themes.

Hani, did you test on all platforms and could only still reproduce on Windows, or did you test only Windows?

If something is fixed for Linux and this patch doesn't cause additional regressions on Windows, it may still make sense to uplift it, and file a follow-up Windows-only bug. If this doesn't help anywhere, we should just re-open this bug.
Flags: needinfo?(florian) → needinfo?(hani.yacoub)
I tested on all platforms and I could only reproduce on Windows.
Should I mark this bug as verified and open a new one for the issue on Windows?
Flags: needinfo?(hani.yacoub) → needinfo?(florian)
(In reply to Hani Yacoub from comment #21)
> I tested on all platforms and I could only reproduce on Windows.
> Should I mark this bug as verified and open a new one for the issue on
> Windows?

Yes please. And I think we can uplift to beta to help Linux users who need high contrast. For Windows, the issue for the High Contrast theme users was fixed in bug 1419152.
Flags: needinfo?(florian)
Based on comment 22 I'll mark this as verified on Ubuntu 16.04 x64 and Mac OS X 10.12.
Since the issue on windows will be fixed in bug 1419152 I will not log a new one.
(In reply to Hani Yacoub from comment #23)

> Since the issue on windows will be fixed in bug 1419152 I will not log a new
> one.

It will not be fixed in bug 1419152, it's just that the bug here affects mostly people working around the lack of high contrast themes on Linux/Mac, and Windows users can use high contrast.
Comment on attachment 8945532 [details] [diff] [review]
Patch

Low risk, beta59+
Attachment #8945532 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Sorry for the misunderstanding, I logged bug 1438143 for the issue on Windows.
I managed to partially reproduce the bug using an older version of Nightly (2017-11-19) on Windows 10 x64. After I changed the color of the text and the background and I opened a new tab a white flash appeared. 

I retested everything on the latest Nightly 60.0a1 and beta 59.0b10 using Windows 10 x64, Ubuntu 16.04 x64 and Mac OS 10.12, but the bug is still reproducing. If the browser isn't restarted after you change the text color and the background color, that white flash still appears when a new tab is opened.
(In reply to Oana Botisan from comment #28)
> If the browser isn't restarted after you change the text color
> and the background color, that white flash still appears when a new tab is
> opened.

The patch here will only work for new windows (no need for a full browser restart, just opening a new window should be enough).
I retested everything using the info from comment 29 on Windows 10 x64, macOS 10.13 and Ubuntu 16.04 x64 on latest Nightly 60.0a1 and beta 59.0b10 and the bug is not reproducing anymore if the new tab is opened in a New Window.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.