Remove the "addengine-icon" binding

RESOLVED FIXED in Firefox 59

Status

()

defect
P3
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: bgrins, Assigned: Paolo, Mentored)

Tracking

(Blocks 1 bug)

unspecified
Firefox 59
Points:
---

Firefox Tracking Flags

(firefox59 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(2 attachments)

(Reporter)

Description

a year ago
The "addengine-icon" binding is attached to nodes created in the search box when a page has a search engine that can be added:

https://dxr.mozilla.org/mozilla-central/rev/b056526be38e96b3e381b7e90cd8254ad1d96d9d/browser/components/search/content/search.xml#1157
https://dxr.mozilla.org/mozilla-central/rev/b056526be38e96b3e381b7e90cd8254ad1d96d9d/browser/base/content/browser.css#657

Steps to see it #1:
- Load https://bugzilla.mozilla.org/
- Click the magnifying glass in the searchbox
- See "Add Bugzilla@Mozilla"

Steps to see it #2:
- Load https://de.pons.com/
- Click the magnifying glass in the searchbox
- Hover "add search engines"
- See menu populated with multiple search engines

See the screenshot for all the configurations.

I believe the content the binding generates can either be directly injected in the two places it's appended or this can be converted to a toolbarbutton-badged with some extra CSS to get the + image to show as a badge
Mentor: adw
Priority: -- → P3
Whiteboard: [fxsearch]
Comment hidden (mozreview-request)
(Assignee)

Comment 2

a year ago
Tested on Mac, Windows, and Linux. There are a few small visual inconsistencies, but they are not regressions.
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED

Comment 3

a year ago
mozreview-review
Comment on attachment 8938954 [details]
Bug 1419198 - Remove the "addengine-icon" binding.

https://reviewboard.mozilla.org/r/209400/#review215954

Looks fine, thanks Paolo.  Maybe a good time to move some of these CSS rules to shared/?
Attachment #8938954 - Flags: review?(adw) → review+
(Assignee)

Comment 4

a year ago
(In reply to Drew Willcoxon :adw from comment #3)
> Looks fine, thanks Paolo.  Maybe a good time to move some of these CSS rules
> to shared/?

I didn't do this in this patch because I wasn't quite sure about how to distribute the rules across existing or new files, and I wanted this to land sooner rather than later, so I did the straightforward update in each file.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=5614845381b3c8372f7ae823f89eeb9042f1d36a

Comment 6

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a44f7f0fa313
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.