[gnome-shell, Ubuntu 17.10] Titlebar is shown despite settings to draw in the titlebar

RESOLVED FIXED in Firefox 59

Status

()

defect
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 1 bug)

Trunk
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
Follow up from Bug 1417933 comment 11. Gnome-shell should support GDK_DECOR_BORDER, we need to investigate why it's ignored on Ubuntu 17.10.
(Assignee)

Comment 1

a year ago
It's because Ubuntu sets XDG_CURRENT_DESKTOP to "ubuntu:GNOME" instead of "GNOME" so the titlebar style is not detected properly and the titlebar is disabled.
(Assignee)

Comment 2

a year ago
Bug 1419456 needs to land before we fix this one.
Depends on: 1419456

Updated

a year ago
See Also: → 1418823
See Also: 1418823
Duplicate of this bug: 1418823

Comment 5

a year ago
mozreview-review
Comment on attachment 8931346 [details]
Bug 1419460 - search XDG_CURRENT_DESKTOP for desktop environment type substring,

https://reviewboard.mozilla.org/r/202482/#review208898

::: commit-message-b6bed:1
(Diff revision 1)
> +Bug 1419460 - search XDG_CURRENT_DESKTOP for DE type substring, r?jhorak

Please add a brief description why this is needed, and to the source code why the substring is checked.
Attachment #8931346 - Flags: review?(jhorak)
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Blocks: 1421593

Comment 7

a year ago
mozreview-review
Comment on attachment 8931346 [details]
Bug 1419460 - search XDG_CURRENT_DESKTOP for desktop environment type substring,

https://reviewboard.mozilla.org/r/202482/#review209720
Attachment #8931346 - Flags: review?(jhorak) → review+

Comment 8

a year ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/f6bd72fc9215
search XDG_CURRENT_DESKTOP for desktop environment type substring, r=jhorak
https://hg.mozilla.org/mozilla-central/rev/f6bd72fc9215
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.