All users were logged out of Bugzilla on October 13th, 2018

Entry Point Not Found [?Right@nsACString@@QBEIAAVI@I@I@Z]

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: dave.kimberley, Assigned: dveditz)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0+) Gecko/20020502
BuildID:    2002050208

Just installed latest nightly.

On starting Mozilla or on selecting Help->About Plug-ins get the following alert:

----------------------------
Mozilla.exe - Entry Point Not Found

The procedure entry point ?Right@nsACString@@QBEIAAVI@I@I@Z could not be located
in the dynamic link library xpcomm.dll

OK
----------------------------

After clicking OK everything appears to work correctly.

Reproducible: Always
Steps to Reproduce:
1.Select Help-About Plug-ins
2.Error message appears
OR
1.Start Mozilla
2.Error message appears

Comment 1

17 years ago
This can happen if you omit to uninstall older builds first.
Can you provide the timestamps of the files

impComm4xMail.dll
msgMapi.dll

and compare to the timestamps of the other dll files.
(Other outdated dll's are also of interest)

Probably dup of bug 141438
(Reporter)

Comment 2

17 years ago
Mozilla was uninstalled first.

Did not find the following DLLs in the Mozilla directory.

impComm4xMail.dll
msgMapi.dll

Did a find on drive C

Found impComm4x.dll and msgMapi.dll in Netscape 6 directory

impcom4x.dll Created 02 November 2001 Modified 28 November 2001
msgMapi.dll  Created 02 November 2001 Modified 28 November 2001

Can Mozilla and Netscape 6 both be installed on the same PC?
I have not had problems with earlier Mozilla builds coexisting with Netscape 6.

Comment 3

17 years ago
->installer
Assignee: Matti → dveditz
Component: Browser-General → Installer
QA Contact: imajes-qa → bugzilla
Summary: Entry Point Not Found → Entry Point Not Found [?Right@nsACString@@QBEIAAVI@I@I@Z]
This is probably due to alecf's recent removal of Left/Right/Mid from
nsAC?String......
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
I had a version of this towards the end of the install of build 050308 on a win 
NT machine.
My version was headed in the title bar of the popup box:

OlemainThreadWndName: Mozilla.exe - Entry Point Not Found

Inside the box it said:
The procedure entry point ?Mid@nsAstring@@QBElAAV1Alli@ll@Z could not be locted 
in the dynamic link library xpcom.dll

I'd class this a **serious bug - the browser won't take to links now!
Also it won't close down - the "exit mozilla" option is greyed out in the set of 
choices at the bottom icon bar, and attempting to close down mozilla didn't 
exactly, since there's enough left (I had the quicklaunch option set to yes) to 
prevent it from starting again! Bad.

Comment 6

17 years ago
>I'd class this a **serious bug - the browser won't take to links now!

I'm pretty sure this bug has nothing to do with that...
*** Bug 142241 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Reinstalling Mozilla 1.0.0+ under Win2K SP-2 was successful and solved the
reported problems. I could not reproduce my error(s). Thanks for the help.

Comment 9

17 years ago
*** Bug 144070 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
this bug is due to having installed a third party extension like spellchecker,
calender, etc. The third party extension uses some deprecated modules/functions.

To avoid this bug remove the entire mozilla.org directory and the reinstall
mozilla and then install the newest version of the extentsion.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 11

16 years ago
v
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.