Navigating from new tab page switches the tab label to "about:newtab"

RESOLVED FIXED in Firefox 59

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ttaubert, Assigned: ttaubert)

Tracking

(Blocks 1 bug)

unspecified
Firefox 59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

STR:

1) Open a new tab (i.e. about:newtab)
2) Click one of the thumbnails

Alternative:

1) Open a new tab (i.e. about:newtab)
2) Enter "mozilla.org" and hit Enter

The issue here is that before (2) we show "New Tab" as the tab label. As soon as you click the thumbnail or hit Enter in the Awesomebar we switch the tab label to "about:newtab", until we get the target page's tab title.

This adds flickering for a very common action, and is an implementation detail we shouldn't expose.
That's actually a Session Restore issue, caused by, I think, switching the tab to be remote.

https://searchfox.org/mozilla-central/rev/7f45cb7cc0229398fc99849bdc150cb6462d6966/browser/components/sessionstore/SessionStore.jsm#2714
Component: Tabbed Browser → Session Restore
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Pushed by ttaubert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/923256103e56
Don't set tab label to about:newtab when navigating and changing remoteness r=mconley
https://hg.mozilla.org/mozilla-central/rev/923256103e56
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
While investigating bug 1423256, I've found that this patch has caused the "New Tab" label to no longer be displayed on the Activity Stream page, while it is displayed on the old about:newtab.

The initial issue which you were seeing was caused by Bug 1413550.

A similar behavior can be observed for the about:home page. Instead of the "New Tab" label, "about:home" is displayed instead.
Tim, do you want me to log a separate bug for this?
Flags: needinfo?(ttaubert)
Blocks: 1423256
I commented in bug 1423256. We can probably revert this patch here if people fix the activity stream page.
Flags: needinfo?(ttaubert)
I have reproduced this bug with Nightly 59.0a1 (2017-11-30) on Windows 8.1 , 64 Bit ! 

This bug's fix is Verified with latest Nightly 59.0a1 !

Build   ID    20171216100407
User Agent    Mozilla/5.0 (Windows NT 6.3; WOW64; rv:59.0) Gecko/20100101 Firefox/59.0

[bugday-20171213]
Comment on attachment 8933572 [details]
Bug 1422246 - Don't set tab label to about:newtab when navigating and changing remoteness r?mconley

Mike Conley (:mconley) (:⚙️) - Backlogged on reviews and needinfos has approved the revision.

https://phabricator.services.mozilla.com/D307#7579
Attachment #8933572 - Flags: review+
Blocks: 1429119
You need to log in before you can comment on or make changes to this bug.