Closed Bug 1423256 Opened 2 years ago Closed 2 years ago

Missing favicon and/or title for some tabs (navigate, session restore, home button, duplicate, move window)

Categories

(Firefox :: New Tab Page, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 59
Iteration:
59.4 - Jan 15
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- verified
firefox60 --- verified

People

(Reporter: cmuresan, Assigned: andreio)

References

Details

(Keywords: regression)

Attachments

(3 files)

[Affected versions]:
- Firefox 59.0a1 Build ID 20171204234137

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- browser.newtabpage.activity-stream.enabled is set to true in about:config on a clean new profile.

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites.
2. Navigate to a website and open a new tab.
3. Switch back to the previous tab.
4. Restart the browser from the browser console (shift+f2).
5. Observe the New Tab.
 
[Expected results]:
- "New Tab" title is displayed. 

[Actual results]:
- Only the favicon is displayed.

[Notes]:
- The issue is also reproducible when you close and reopen the browser with the "Show my windows and tabs from last time" option enabled.
- The issue is also reproducible with on about:home, but in about:home's case "about:home" is displayed.
- Attached a screen recording of the issue.

[Regression Range]:
Initial breakage:

Last good revision: bc8f24ca5bb3abdab417af45017b91a9a44a0745
First bad revision: def95432b0a17a1b29bef1e6aea9305d69572fb9
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=bc8f24ca5bb3abdab417af45017b91a9a44a0745&tochange=def95432b0a17a1b29bef1e6aea9305d69572fb9

More breakage:

Last good revision: 12a26fcdf0d426093302b22c3aa87dbd4057b5fe
First bad revision: 923256103e56c8f061abe44a47173b0709f2d56a
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=12a26fcdf0d426093302b22c3aa87dbd4057b5fe&tochange=923256103e56c8f061abe44a47173b0709f2d56a
See Also: → 1422906
Potentially bug 1422074 will make things worse as not only do we rely on Firefox to set the appropriate title, we'll rely on Firefox to set the icon.
Depends on: 1422074
If we'd bring the <title> back then we could revert bug 1422246 as well. I didn't realize this was a regression specific to activity stream.
Depends on: 1422246
(In reply to Tim Taubert [:ttaubert] from comment #3)
> If we'd bring the <title> back then we could revert bug 1422246 as well. I
> didn't realize this was a regression specific to activity stream.

If we back out bug 1422246, instead of an empty title you'll see "about:newtab". You should really bring the <title> back.
(In reply to Ed Lee :Mardak from comment #1)
> Potentially bug 1422074 will make things worse as not only do we rely on
> Firefox to set the appropriate title, we'll rely on Firefox to set the icon.

This btw regresses the old non-AS about:newtab page. It doesn't have an icon anymore.
This is uncannily similar to bug 1394012 (but about:newtab instead of about:blank). If we understand how this bug is caused, can we also fix that bug once we have a fix for AS?
See Also: → 1394012
Iteration: --- → 1.25
Priority: -- → P2
Here's restoring one tab each of about:blank/home/newtab then the about:preferences (also restored and focused). Then opening those 3 tabs in a new tab. (Ignore the missing favicon of about:home to be fixed in bug 1422903.)

Given the patch for bug 1422246:
https://hg.mozilla.org/mozilla-central/rev/923256103e56

… seems like a somewhat expected behavior of the code. Although the session restore fix should probably have all of blank/home/newtab set the icon (?) and title of the tab?

Activity Stream was told to remove these in-page declarations to avoid flicker during startup.
See Also: → 1422903
Do we know what our next steps are here?
Flags: needinfo?(edilee)
Iteration: 1.25 → 1.26
The fix on the activity stream side is to restore the <link icon> and <title> tags, but we want to avoid regressing bug 1401955 and its related flickering bugs as per bug 1426916 comment 2.

To do that, we could probably special case the icon updating browser code to not do the update if the icon is already set / the same?

From the P2 prioritization, this regression is something we must fix for 59.
Flags: needinfo?(edilee)
Summary: When a new tab is restored the favicon is displayed, but no tab name → Missing favicon and/or title for some tabs (session restore, home button, duplicate, move window)
Duplicate of this bug: 1427031
Duplicate of this bug: 1426916
Assignee: nobody → andrei.br92
Blocks: 1429119
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Summary: Missing favicon and/or title for some tabs (session restore, home button, duplicate, move window) → Missing favicon and/or title for some tabs (navigate, session restore, home button, duplicate, move window)
Duplicate of this bug: 1428873
Blocks: 1429530
Iteration: 1.26 → 59.4 - Jan 15
Target Milestone: --- → Firefox 59
Duplicate of this bug: 1429334
Duplicate of this bug: 1398465
QA Whiteboard: [good first verify]
I have reproduced this bug with Nightly 59.0a1  (2017-12-05) on Ubuntu 12.04 , 64 Bit!

This bug's fix is verified with latest Beta!

Build ID   : 20180125163041
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [good first verify] → [good first verify] [bugday-20180124]
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Firefox: 60.0a1, Build ID 20180131220303

I have verified that this issue is no longer reproducible on Windows 10 x64, Ubuntu 14.04 x64 and Mac 10.12, with Nightly (59.0a1 from 2018-01-21) and with the latest Nightly (60.0a1) builds installed. Now the favicon and the title are displayed.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.