Firefox 52.5.2 (64-bit) has weird white flashing artifacts

RESOLVED DUPLICATE of bug 1394654

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 1394654
a year ago
a year ago

People

(Reporter: jackiam2003, Unassigned)

Tracking

52 Branch
All
Other
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [specification][type:bug])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
What did you do?
================
1. download and open 52.5.2 (64-bit)
2. the whole browser will flash white, and then open the about page and it will go white and the about page is blank.
3. This effects the 52.5.2 (64-bit) and TorBrowser 7.0.11 and 7.5 a9

What happened?
==============
The main browser flashes white every time it opens and the about page turns Completely white.

What should have happened?
==========================
The browser and about page should not turn or flash white.

Is there anything else we should know?
======================================
im running macOS 10.13.2 (17C88) and I tested this on multiple Mac's running the same version and it occurs on all Mac's. I reported this to TorPeoject here https://trac.torproject.org/projects/tor/ticket/24566
(Reporter)

Updated

a year ago
Severity: normal → major
(Reporter)

Comment 1

a year ago
The report on TorProject contains videos showing the bug occur in TorBrowser, https://trac.torproject.org/projects/tor/ticket/24566

Updated

a year ago
Component: General → General
Product: Mozilla Developer Network → Firefox
Version: unspecified → 52 Branch

Updated

a year ago
Component: General → Graphics
Product: Firefox → Core
(Reporter)

Comment 3

a year ago
The bug only started after I updated my Mac to macOS 10.13.2 (17C88) up from 10.13.1

Comment 4

a year ago
It seems Firefox 57.0b3 is the first version with a fix for that.

Updated

a year ago
Blocks: highsierra

Updated

a year ago
Component: Graphics → Widget: Cocoa
(In reply to Georg Koppen from comment #4)
> It seems Firefox 57.0b3 is the first version with a fix for that.

This may have been fixed by bug 1400057. If this is the case, the following build should be the last build to reproduce the bug:

https://archive.mozilla.org/pub/firefox/nightly/2017/09/2017-09-30-10-03-02-mozilla-central/firefox-58.0a1.en-US.mac.dmg

And this build would be the first one to fix it:

https://archive.mozilla.org/pub/firefox/nightly/2017/10/2017-10-01-10-03-35-mozilla-central/firefox-58.0a1.en-US.mac.dmg

Could someone confirm?
Flags: needinfo?(jackiam2003)
Flags: needinfo?(gk)
(Reporter)

Comment 6

a year ago
it does not look like it is the same bug as 1400057. the bug does Not occur on https://archive.mozilla.org/pub/firefox/nightly/2017/09/2017-09-30-10-03-02-mozilla-central/firefox-58.0a1.en-US.mac.dmg
Flags: needinfo?(jackiam2003)
Thanks for checking! Could you run mozregression[1] to figure out when exactly this got fixed?

[1] http://mozilla.github.io/mozregression/
Flags: needinfo?(gk) → needinfo?(jackiam2003)
(Reporter)

Comment 8

a year ago
(In reply to Stephen A Pohl [:spohl] from comment #7)
> Thanks for checking! Could you run mozregression[1] to figure out when
> exactly this got fixed?
> 
> [1] http://mozilla.github.io/mozregression/

I do not know enough about mozregression to use it.
Flags: needinfo?(jackiam2003)
You should only need to run the following commands in a Terminal window to use mozregression:

sudo easy_install pip
sudo pip2 install -U mozregression
mozregression --find-fix --good 57 --bad 56

A number of Firefox versions will open in succession to narrow down when this was fixed. Simply type "good" or "bad" in Terminal based on whether or not a build reproduces the bug.
Flags: needinfo?(jackiam2003)
(Reporter)

Comment 10

a year ago
Finished, thanks.

15:38.89 INFO: First good revision: 10a488d8110e2c2fd293978e3886ebe793bec1ba
15:38.89 INFO: Last bad revision: ef1033c0be43818cca1cba678c43f639d0ca4e6d

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ef1033c0be43818cca1cba678c43f639d0ca4e6d&tochange=10a488d8110e2c2fd293978e3886ebe793bec1ba
Flags: needinfo?(jackiam2003)
Thank you! So this was fixed by bug 1394654.
Depends on: 1394654
An uplift request could be made for the patch in bug 1394654. I don't know what the chances are that it will get uplifted. Alternatively, Tor may be able to take that one patch separately.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1394654
Duplicate of this bug: 1429443
You need to log in before you can comment on or make changes to this bug.